Preview and Beta: Amazon Echo Control


You’re absolutely right. Setting the volume prior to sending worked.

I hadn’t noticed earlier, but thanks to your note, I realized the TTSVolume channel was being set to ‘0’ for some reason when using this latest binding. This is despite the main Volume channel being set > 0.

This appears to be true of all the echos around the house.


Thanks for testing. Its a bug, zero should be “do not change volume, use the current one”. The fix is pushed and on the way.

Did you also fix the issue from @richaardvark?

I don’t use the lastvoicecommand channels usually, so I’m not sure what typical response time should be.

In testing this latest version, the update seems fairly fast for me. lastvoicecommand items update within 1-5 seconds.

1 Like

Still waiting for an estimation of the previous timespan compared to the current. I didnt recognize a long delay so its still necessary to verify this as an issue.

I tried some minutes ago and it did work with the .com address. My experiments with .de required me to reset my password…

Sometimes i am able to login and sometimes not. Yesterday i logged out to verify the comment of @mstormi and was not able to log in after it. Today i tried to find the issue and after some login fails i was able to login. I created a test account and was again not able to login. This behavior is verified by other alexa developers.

I’m having the same problem. I logged out to try to update my ID because I was having issues with my AmazonEchoControl smart home devices and now I’m unable to login whatsoever. Super annoying!!!

I’m going to try to call Amazon Echo technical support now but I’m sure they will have no clue what the hell I’m talking about, lol.

I’m completely out of luck. Can’t log in or do anything whatsoever.

It keeps saying my email address is invalid even though it is not.

Please wait 12-24h. We are working on that issue and it seems time is important

1 Like

Thank you @J-N-K. I will wait patiently. :heavy_check_mark:

Edit: I don’t know if it helps or not, but this is what I see when I try to reset my password using the Amazon Echo Control page. So it does seem to be an error with the openHAB server/binding.

Edit 2: Good news! I was able to sign back in again to the binding using my mobile phone’s browser! :heavy_check_mark::tada:

Source IP eventually makes for a difference, too, Amaz*n processing likely to depend on that…
(here: the IP of your mobile vs. that of your fixed net router)

1 Like

I am up and running again, logged in, and using the latest binding (2.5.7). For me, with this version of the binding, the LastVoiceCommand is instant/reacts normally maybe 1 out of every 8 times, but is very slow every other time, taking as long as 8 to 20 seconds or more, or not working at all. :frowning:

The same seems to be true with TTS: randomly, every now and then, it will work properly but most of the time it is not working at all with this newest binding. I have made sure my volume is turned up as well. :heavy_check_mark:

I will see if I can capture any error messages via the console and report back.

@J-N-K Update: I enabled TRACE logging via the console and then gave Alexa/my Echo Dot a couple of commands, while watching the logs. There did not seem to be anything abnormal in the logs, even though the LastVoiceCommand information was still very slow to load.

For now, I’m going to switch back to the 2.5.6 version because it was working much better overall for me and I can live with that occasional weird bundleFile error in the log for now. I’m happy to switch back to the newest version though and I’m happy to provide any other information or help with testing anything.

Thank you all so very much for your help with this and for maintaining this awesome and essential add-on!

Update 2: None of my smart home devices are working any longer, either with version 2.5.6 or 2.5.7. Existing devices I have defined in my .things file are no longer recognized in PaperUI and no new smart home devices appear in my inbox. :frowning:

Update 3: Locked out of my account and unable to login again, regardless of IP address. :frowning: I’ll just wait patiently for a fix. :person_in_lotus_position::heavy_check_mark:

Same problem here.

Did you see the „we need to reset your password“ message?

I did not. I was finally able to log back in again by using my cell phone’s browser in “incognito” mode.


thanks for testing.

Can you provide a log?
Please set your tts volume to another level than the standard volume and send some tts until the delay happens. You can set the log to info, thats ok. Because its possible to see the state change of the tts and the volume state change.


I would love to help with providing a log. Unfortunately, I’m once again logged out of my Amazon account in the binding and have not found a successful way to log back in this time. I’ve tried using a proxy IP address, have tried my mobile phone, different computers/tablets but unfortunately I am receiving the email error when I try to log in :-/

You randomly get a valid id, so at the moment the only way is: restart openhab or the binding, try to login, restart…, try to…, aso. One time you will get a valid id. Ooor, wait some hours and we will provide a new jar to fix the login.

1 Like


can you please try to Login with the following jar:

Link removed.


Trinitus01 (Tom)

1 Like