Private Cloud and alexa skill

In the last few days I’ve been trying to set up my own cloud and connect it via the Alexa skill. Successfully I installed a cloud server with a apche2 reverse proxy (LE certificate) and connected my openhab installation with the cloud. I also managed to deploy the skill with ask-cli. I can succesfully connect the the skill to either openhabcloud or amazon-developer-account (I tried both options). However searching for new devices is not working. In the amazon lamba log I see the call for discovery, followed by a timeout after 10 seconds. In the log of my reverse proxy only the actiity for connecting the skill to the cloud is seen, none for the discovery.
My question now is: Has anyone seen the same issue and knows how to solve it?
Thanks fhz

This is the call seen in the lambda-log just after starting device discovery, followed by a timeout after 10s

2024-02-03T09:42:10.852Z c094276d-01f6-4612-9a5e-7b279e36177e INFO Received event: {
“directive”: {
“header”: {
“namespace”: “Alexa.Discovery”,
“name”: “Discover”,
“payloadVersion”: “3”,
“messageId”: “16e86719-57c7-4714-9016-a04e730ecd16”
},
“payload”: {
“scope”: {
“type”: “BearerToken”,
“token”: “IYwuBuzcQSDHu5k7whnFUmPaJiCorV1ya0abUXV37iPk7h5rJoZDAVN9YIPSfwnxFzbiaqCZdzhnYv3kgijN7cmrAaHpGEb3HuCEpvl4iEdVxW9uvAN7EyV4eBPTXkJ0N59mL7hPOMghaoU0DZs14ZyTqMzJsqfOhZSh3DWhfzzn3L13yIACgQWxBFzvMX6fE9DAPyhyUjNJV5xQ8TisN6xN0brNBmxQPk14”
}
}
}
}

Assuming that you configured the skill to use your cloud connector OAuth2 server, you should see an authentication request followed by REST API calls. Is your REST API endpoint accessible from the Internet?

The skill is configured to use my openhab cloud server and the rest api of this server is accessible from the internet. However, I see only the OAuth responses for the skill connection, none for the discovery

Did you configure the OpenHABBaseURL parameter in your ask-resources.json file to point to your server root level path?

Exactly, but only there. Looking through the files, I find under .github/workflows/deployment.yml still OPENHAB_BASE_URL: https://myopenhab.org

That doesn’t come into play here. This is for the GitHub Actions workflow that is used to deploy the live skill.

Unfortunately, I don’t know what to tell you at this point. This is either a skill configuration or a networking issue in your environment. The fact that the skill is timing out means it is waiting for a response to a request it has sent reaching the Lambda function timeout.

You can try to enable debug log level on the OH side and add environment variable NODE_DEBUG=https to your Lambda function. It will log every https requests the skill is doing. You can also confirm the Lambda environment variable for your OH base url.

NODE_DEBUG=https did not change anything in the CloudWatch protocol-stream. I still have no clou what is wrong

Are you saying you didn’t see any extra logging after setting the environment variable and triggering a discovery?

Any extra logging you can enable with your reverse proxy?

Were you able to confirm your OH base url?

Yes, NODE_DEBUG didn’t change anything

I was looking at all logs of the proxy and could not see any hit
Yes, OH base urls is set correctly

It’s NODE_DEBUG not MODE_DEBUG.

Also, my previous statement was incorrect since you are using the cloud connector which should be connecting to your OH REST API on your local network. So it doesn’t have to be directly accessible from the Internet only your cloud connector should be.

I found the culprit: I had a GeoIP-Firewall activated on the Router, including blocking Ireland