"Problem accessing /start/index Not Found" on Raspberry Pi

I’m on the Raspberry Pi 3 Motherboard B and I installed openHAB 2 via these instructions: http://docs.openhab.org/installation/rasppi.html

Unfortunately, when I access through the web interface, I’m getting

Problem accessing /start/index. Reason:

    Not Found

This is my java version:

java version "1.8.0_65"
Java(TM) SE Runtime Environment (build 1.8.0_65-b17)
Java HotSpot(TM) Client VM (build 25.65-b01, mixed mode)

I believe I have OracleJDK installed instead of OpenJDK since I know it causes problems. Aside from seeing the Not Found error through the web interface, I’m also seeing this when running start_debug.sh manually:

Launching the openHAB runtime...
Listening for transport dt_socket at address: 5005

                          __  _____    ____
  ____  ____  ___  ____  / / / /   |  / __ )
 / __ \/ __ \/ _ \/ __ \/ /_/ / /| | / __  |
/ /_/ / /_/ /  __/ / / / __  / ___ |/ /_/ /
\____/ .___/\___/_/ /_/_/ /_/_/  |_/_____/
    /_/                        2.0.0.b3

Hit '<tab>' for a list of available commands
and '[cmd] --help' for help on a specific command.
Hit '<ctrl-d>' or type 'system:shutdown' or 'logout' to shutdown openHAB.

openhab> [Fatal Error] :1:3: The markup in the document preceding the root element must be well-formed.

I’m also seeing this error in my logs

2016-06-19 23:36:49.230 [ERROR] [org.eclipse.smarthome.model.script  ] - [org.eclipse.smarthome.action.transformation.action(82)] Circular reference detected, getService returning null

Anyone know why this could be happening? I’ve tried waiting 5 minutes to wait for openHAB 2 to boot up but nothing changes. Thank you!

Java version is ok, though it’s a bit out of date :wink: current version is 8u91 (1.8.0_91-b14), this build is for 64bit, but should be something similar.

Which version of OH2 did you install? testing or stable? online or offline?

The error message leads to a malformed document, so maybe it would be the best advice to completely uninstall (purge) and reinstall openHAB2, because maybe there was an error through file transfer.

I installed 2.0.0.b3, tried both offline and online. I’m not sure if it’s due to file transfer since I installed using packages from the repositories. I’ve also uninstalled and reinstalled many times. I will try updating Java however to see if that changes anything. Thanks.

I’ve upgraded Java:

java version "1.8.0_91"
Java(TM) SE Runtime Environment (build 1.8.0_91-b14)
Java HotSpot(TM) Client VM (build 25.91-b14, mixed mode)

Unfortunately I still have the same issues. Any other recommendations? Thanks!