Problem communicating with Tapo P300 after firmware update

I’m running OH 4.0.4.

I just updated my TP300 to firmware 1.0.13 Build 230925 Rel. 1520200 and the binding can no longer communicate with it. Here is the error message:

22:47:32.156 [TRACE] [trol.internal.api.TapoDeviceConnector] - (tapocontrol:P300:98533:ps1) sending login to url 'http://XX.XX.XX.XX/app'
22:47:32.157 [TRACE] [ontrol.internal.api.TapoDeviceHttpApi] - (tapocontrol:P300:98533:ps1) create handhsake with payload: {"method":"handshake","params":{"key":"-----BEGIN PUBLIC KEY-----\nMIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQCB2F9NKFJiXk3axAbAefNDr/Q/9bk1sFnvXZO6\r\n5zZHRmqMN4SNBlVFGszwmnu59DH9uQusjpH0/tE8iXYwBru6eHctrcFcUSdT+vb\r\nAfOb4H4qQhoKOHmK92y07ujMusxEIadQXwIDAQAB\n-----END PUBLIC KEY-----\n"},"requestTimeMils":1700516852157}
22:47:32.159 [TRACE] [ontrol.internal.api.TapoDeviceHttpApi] - (tapocontrol:P300:98533:ps1) sendRequest to 'http://XX.XX.XX.XX/app' with cookie ''
22:47:32.170 [DEBUG] [ontrol.internal.api.TapoDeviceHttpApi] - (tapocontrol:P300:98533d:ps1) device returns errorcode '1003'
22:47:32.172 [TRACE] [ontrol.internal.api.TapoDeviceHttpApi] - (tapocontrol:P300:98533:ps1) not logged in
22:47:32.173 [DEBUG] [apocontrol.internal.device.TapoDevice] - (tapocontrol:P300:98533:ps1) startScheduler: create job with interval : 30 SECONDS

I tried deleting the Thing and creating it again by adding the Thing discovered by the scan (yes, it is found) or adding it manually but the problem persisted.
Tapo P115 plugs have not been updated and continue working fine.

1 Like


I have not the same, but another problem since update

2023-11-21 19:14:32.952 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'tapocontrol:P300:myBridge:SZTisch' changed from OFFLINE (COMMUNICATION_ERROR): unknown api error (-1) to UNKNOWN: unknown api error (-1)
2023-11-21 19:14:32.953 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'tapocontrol:P300:myBridge:SZTisch' changed from UNKNOWN: unknown api error (-1) to OFFLINE (COMMUNICATION_ERROR): unknown api error (-1) 

The message shown up every 30 seconds

Have somebody an idea?

Thx Daniel

Do you have the same firmware version?

Yes I have the same

I created this bug report: [tapocontrol] Problem connecting to Tapo P300 Power Strip after firmware update · Issue #15940 · openhab/openhab-addons · GitHub

Same issue after P110 firmwareupdate to v1.3.0
The old FW v1.2.3 has no issues. Releaseinfo claims “improved local security”.

1 Like

Same here.
The P110 with v1.1.6 work flawlessly,
the P110 with v1.3.0 do not

The P110 issue with the newest firmware was for me solved here.
I am not sure, if the solution works for the P300 device too.

Worked for me too,
Thanx for this

Thanks for the info, @magicofit.
It worked for the P300, and the P115 plugs which haven’t received any firmware update.