Problem Creating TP-Link Kasa Bulb Things

I wonder if someone that has experience with this, can help me solve it. I’m using OpenHab 4.0.3, and I’m trying to create corresponding things for four TP-Link Kasa KL125 bulbs that I’ve just bought. I have already installed and configure the bulbs in the Kasa Android app. I even connected them through Alexa and Google Assistant, and I am using them that way. Now I want to configure them in OH, so that I can trigger actions based on motion movements, camera triggers and so on. Problem is, I haven’t been able to do just that after trying for three days. I already installed the binding (TP-Link Smart Home Binding) and the bulbs appear in my Inbox. I have tried the automatic and the manual options to no avail. I event tried a workaround I found on this forum telling me to register them with the IP and placing whatever text as a device ID. The IPs are all statics. Problem is, after I configure the IP and hit save, it will show as online for about a minute. Then, they come offline again, and after getting into the config, I see that the IPs have been changed automatically to something of the sort of (My IPs are 192.168.xx.xx). The error message says: “Connection refused”, which leads me to believe that the problem has to do with authentication. So, I wonder, how can I send usr and pwd through OH so that they authenticate before connecting? I also read something in the forums about opening up “Remote Control” option in the Kasa app, but that option is not present there. The app has an option about “Third-Party Services”, but it only shows Amazon Alexa, Google Assitant, IFTTT and Samsung SmartThings. Why am I missing? I know the model is compatible with OH because it says so in the documentation.

Thanks in advance,

If anyone has this problem in the future, I’ve found out the cause. I’m using OpenHAB as a guest in VirtualBox and the guest has the network attached by default. I guess the internal DHCP server is the one giving me a different IP and, therefore, the “Connection Refused” message.