Problem inserting my fibaro Door Opener (FGK-101)


first of all I’m a new in this area. I installed openhab on a raspi PI, according apt-get and HABmin1.

I’m using a AEOTEC Gen5 Stick it seems all is fine. HABmin shows the stick a node1 Zwave USB controller, light is green.

------------Number of Nodes Found Registered to ZWave Controller-------

  • Nodes = 1

So my next step was to insert the fibaro FGK-101 Door / Windows
opener by tripple clicking. I have 3 ones but all inserting tries
failed. I tried both options BACK button and internal tmp button. Reset doesn’t helped

sudo /etc/init.d/openhab status -l shows at the end of the output:

Node 1: Neighbor update failed several times


Node 255: Timeout while sending message Requiring 2 attempts.

During startup the only error message ist software reset is false?

I’m no idea whats wrong? Any ideas what I can do?

Many thx in advance


These devices can be a bit tricky to include. You need to keep triple clicking until the Z-Stick flashes quickly to indicate successful inclusion. Can take a while and require very rapid clicking!

As you can see that device definitely works fine with openhab:

Try again and again, my device also needed a couple of attempts to success

Yep, I have 4 of these around my place, all working very nicely with an Aeon Labs Gen 5 Z-Stick.

Thx I will try again … one question regarding the gen5 stick he is blinking and changing the led color from blue yellow etc. in a regular manner, is it normal behavior

Yep the Gen 5 stick flashes multi-colours in normal operation. I asked the same question when I got mine :slight_smile:

:slight_smile: thx, one question how do you start openhab (I use P2 / Jessie Nobs1.5)
There are several option on the openhab-webpage

Start openHAB - manually
Init based on sysVinit (e.g. Debian 7 / Ubuntu 14.x and earlier)
I use this option

  • sudo /etc/init.d/openhab start
  • sudo /etc/init.d/openhab status
    Init based on systemd (e.g. Debian 8 / Ubuntu 15.x and higher)
  • sudo systemctl start openhab
    Start openHAB - at system startup
    Init based on sysVinit
  • sudo update-rc.d openhab defaults
    Init based on systemd
  • sudo systemctl daemon-reload
  • sudo systemctl enable openhab
    Is there a webpage explaining the differences.

Further Question about using Gen5 Stick Openhab recommends not using soft reset. How can I switch it off?

With Jessie the systemd option was published, the older Wheezy uses init. You still can use init with Jessie, but systemd is the preferred method.

Manual init/systemd: start/stop openhab anytime.
System start up options: openhab is started automatically after a reboot of your Pi.

It should be off by default, at least for my stick.
If you intend to use habmin for configuration changes (recommended), there is an option in your openhab.cfg:
Do not set it to true (it is false by default, so not using it at all should be okay)

Hi Guys,

I grow more and more desperate … in the meanwhile a have horny skin on my fingertips. Openhab and Habmin are stating without any error messages …but I don’t succeed in inserting the fibaro stuff.
One can we compare the content of the addons directory. I use …
pi@raspberrypi://usr/share/openhab/addons $ ls -l
insgesamt 2288
-rw-r–r-- 1 root root 1202164 Jan 10 22:14 org.openhab.binding.zwave-1.8.0.jar
-rw-r–r-- 1 pi pi 1134175 Okt 2 13:15
-rw-r–r-- 1 root root 126 Jan 10 22:31 README

Do you think, it makes sense to compare other folders?
The only thing I don’t understand … I configured

#: sudo update-rc.d openhab defaults

doing only this, HABMIN doesn’t start I have additionally to to
sudo /etc/init.d/openhab start (Debian7, Wheez)
sudo systemctl start openhab (Debian 8, Jessie)
Habmin shows that mein gen5 Stick ises
API 1.0, zwave Version 3.95
Status Last packet send/receive none)
Node Stade alive done date …
Dead false
Listening true

one further question how do i revoke sudo update-rc.d openhab defaults?

Thx for your patience

The content of your addons folder looks okay.

Regarding start of openhab:

you can start openhab manually with
sudo /etc/init.d/openhab start or
sudo systemctl start openhab depending on your linux distribution

You have to do this after every restart of your pi.

You can also configure your pi to automatically start openhab on reboot:
sudo update-rc.d openhab defaults or
sudo systemctl daemon-reload
sudo systemctl enable openhab depending on your linux distribution.

This you only have to do once!

I read in another older post that people have had problems with the systemd options under Jessie, if that is also the problem in your case you should use the init versions:

sudo /etc/init.d/openhab start and
sudo update-rc.d openhab defaults

To disable autostart of openhab you may use:
update-rc.d openhab remove