Problem Setup Smart Radiator Thermostat for Z-Wave

Hello everybody,
In the last weeks I´m trying to test a wide variety of sensor & actuators which work with some kind of wireless protocol (mqtt, zigbee…). Now is the time for Zwave.

Normally (and thanks to the maintainer Chris Jackson for the useful information), zigbee devices are discovered following this sequence: -> power on the device -> start the scan with openhab -> reset the device during the scan.

I´m trying something similar with Z-wave devices (in my case a radiator thermostat) but unfortunately my controller isn´t able to find the device. I tested different configuration of my Z wave controller but also didn´t work…

I´m not expert with Z-Wave, but reading the logs I think something is not working fine with the controller… (I use [HUSBZB-1] which already works with zigbee and the Z-Wave controller is also “online”.

I hope someone has another idea which I didn´t have during the last week.

Thank you in advance!


This text will be hidden

For Z-Wave you need to put the controller into inclusion mode and then put the device into inclusion mode. Many recent devices start in this mode when powered on if not already part of a Z-Wave network.
The Thing can then be discovered by OpenHAB and added.
The binding then needs to fully discover the device. You likely need to wake up battery powered devices many times to complete this process.

Hi Bruce,
thank you for your answer. I´ve read about putting the controller into inclusion mode and about the “many wakes up” necessary for battery devices…

The second I tried lot of times during the 120 sec that my controller is looking for incoming devices… but my question is about putting the controller into inclusion mode. Do I need something special or just the controller set-up that I have and start the “Scan” operation from Paper UI… Am I missing something related to this “Inclusion Mode”?

I am sure you can do that from the Paper UI but HABmin is the preferred UI for Z-Wave tasks. I have not done that in the Paper UI.

Since I tagged this thread as z-wave others will be along shortly.

I have tried it through Habmin… the result is the same…

Nothing happens, even waking up my device couple of times…

Really - please provide the logs - not a picture of your monitor. It’s absolutely impossible to process this and it’s only an extremely small part of the log. There’s also an exception showing at the top of the screen - what is that? Is it related?

In HABmin click on the magnifying glass with the plus sign & select Z-Wave Binding if necessary. That puts the controller into Include mode.


You should then see alerts from the button beside the time. From that menu you can select the device to add to openHAB & start the discovery process.


I see this is a Eurotronic device - I’m not sure if they are available in the USA (I guess you are in the USA though - right?).

1 Like

That also brings up the question about whether they have a US region controller.

No, I find my self in Europe right now.
But should it matter? Because the Eurotronic device is also Zwave Plus certefied.

Yes - it matters!

The controller you are using is only available in the USA! It will not work in Europe.

I just thought that if a controller is certified with the standard Z-Wave should be compatible with all Z-Wave devices (doesn´t matter the where they are from)…

That´s mean Z-Wave standard is compatible depending of the region?

For example I´m using the same usb stick with european zigbee devices… I was waiting for same behaviour assuming that we are talking about a standard…

No - there are various regions, so you MUST use a controller that is from the same region as your devices. Different regions use different frequencies due to regulations in different parts of the world.

Your controller will not work with EU devices. Full stop. This is why it doesn’t work.

The EU uses 868MHz, while the US uses 915MHz. There are a number of different specifications around the world - the ZWave standard is exactly the same, but due to licensing requirements they use 3 different frequencies.

Zigbee does not divide the world into regions.

Okay Chris, I get it.
Sorry about the logs, I will post it next time in the proper way…
I didn´t know this fact regarding Z-Wave controller and for sure as you say this is the reason why it´s not working.

I will get a “european” Z-Wave controller and share my experience.
Thank you all, and have a nice Home-Automation Sunday :star_struck:


Sorry I forgot, do you have some recommendation regarding an EU USB Z-Wave controller?

1 Like

Really any of them are fine. Currently most adaptors are the same and my only suggestion is to avoid the very new series 7 devices (although I’m not sure they are generally available).

The Aeotec 5th Gen, or the UZB3 are fine.