Problem to access my openhab2 dashboard

Hey friends,

i’ve recently installed myopenhab_cloud and openhab2 platform on my virtual machine Ubuntu distribution, they are working fine, but when I try to access remotely my dashboard i get this error


i’m using chrome webbrowser. look at these images for more clarifications.

  • openhab dashboard.

  • myopenhab_cloud web interface.

  • myopenhab cloud error.


I forgot to set the system parameters

    "system": {
      "host": "<your-openhab-cloud-host>",
      "port": "443",
      "protocol": "https",
      "logging": "info",
      "subDomainCookies": false

What did you set the host parameter to?

I am trying to use the docker image of openhab-cloud.

Hi ScheissSchiesser,

Take a look at this issue openhab-2-in-docker, maybe help you. :slightly_smiling_face:

Sorry, that didn’t seem to help. I am looking for specifically what you set the host parameter to. If the point of openhab-cloud is to not have to open other ports besides my openhab-cloud instance to be able to access my openhab2 installation, I am confused about this host parameter. The links in the openhab-cloud homepage break when setting this to the local network IP address of my openhab install and attempting to access it from outside my home network.

So firstly you must rename the file config-production.json as mentioned in this post OpenHab Cloud Installation. and next edit your system snippet.
this is my local configuration:

    "system": {
      "host": "", //you openhab2 installation ip
      "port": "8080", // the 8080 openhab2 installation port
      "protocol": "http",  
      "logging": "info",
      "subDomainCookies": false

Don’t forget "registration_enabled": true.
(web interface) openHAB UUID and openHAB Secret respectively in /var/lib/openhab2/uuid and

If you would to access your openhab2 installation directly without the 8080 port, install Apache and enable mod_proxy check the link below

How To Use Apache as a Reverse Proxy with mod_proxy on Ubuntu 16.04
About the outside network you should configure the Port Forwarding parameter in your router. ‘there are a lot of options like DDNS, Remote Access’.

Hi @bouali

Thanks for your response. I believe I have figured out the correct settings. I believe we need much better documentation of this config file to properly configure openhab-cloud for new users.

I think that the information you’ve provided is actually not the intended use-case. Below is my explanation for how I think this is intended to work:

"system": {
  "host": "<host-name-or-IP-address-of-your-openHAB-cloud-installation", //your openhab-cloud installation IP or hostname
  "port": "8000", // the internet-accessible port which points to your openhab-cloud installation port.
   // for me, this is port 8000. I opened up port 8000 on my router, which points to my local port 8080 in my home network (through my router's software).
  "protocol": "http",  
  "logging": "info",
  "subDomainCookies": false

This information seems to be used by openhab-cloud to be able to correctly build it’s own webpage and nginx proxy. The idea is that you’ve already pointed openhab-cloud to your openhab2 installation using the UUID and secret. The openhab cloud connector add-on for openhab2 handles the connection between your openhab2 install and openhab-cloud. You provide the cloud-connector with the IP of your openhab-cloud instance. And then you provide the openhab-cloud instance with the UUID and secret. And now you can login to your openhab-cloud instance and connect to your openhab2 installation without having to expose your openhab2 installation to the internet.

Does this make sense?


Sorry for my late reply, I was busy. i suggest to test your installation with myopenhab. you can follow this link too How to setup openHAB Cloud….