Problem with flashing Sonoff Zigbee bridge to tasmota firmware; Failed to connect esp8266

Hello everyone. I’m now doing my smart home with zigbee device. Recently I’ve just bought some set of Zigbee device eg; SNBZ-02, SNBZ-03. Zigbee light switch and Zigbee RGB controller GL-C-008 (GLEDOPTO) and it’s worked fine with Zigbee2mqtt + C2531 USB Dongle

I’ve just recently buy Sonoff Zigbee bridge and want to flash it with Tasmota firmware. expect to use it with openhab zigbee-binding. So I follow instruction from below link:


I’m using CH340 USB TTL module and connect to Sonoff Zbbridge as diagram below

The sonoff zigbee bridge show permanently green light after connect USB to my laptop

Then I’m trying to flash it with Tasmotizer and It’s appear error: Failed to connect ESP8266. Time out
even I tried with PyFlasher. It’s also cannot connect to esp8266 module. like with Tasmotizer.
I’ve also try switched between TX RX. The result still the same.
Are there anyone here facing this problem before?. Or did I’ve done anything wrong?

Sorry if I explain not clearly and my bad English grammar. I’m very new here. :sweat_smile:

Is your computer Windows or Linux? Perhaps a permissions issue with the USB port.

Can you check that you followed exactly the steps from here? These are the official instructions:

I know a few people here have Z2T on a Sonoff ZB bridge, but not many. You may have more luck on the Tasmota Discord support channel.

Thanks for replied. I’m using Windows 10 to proceed
I’m stuck at Flash ESP8266 that I’m quite sure I’ve followed all instruction as your given link.
I try to find the solution for 2 days but still cannot get it. :frowning_face:

That solution looks like a troubleshooting nightmare to me. The devices would need to be supported by both Z2T and the Zigbee binding here. You would be on your own for figuring out which software was misbehaving.

In my experience, the simpler the approach, the better & more reliable. Just my 2 cents worth.

Good catch.

@adxnop do you know how to do this? I thought Z2T only pumped out MQTT messages, so I’m not sure it can be used with the openHAB Zigbee binding - I’m interested if this works! It kind of defeats the point of using the Sonoff Bridge though, if you still need to have it plugged into the machine that is hosting openHAB: you’re no better off than with your cc2531 stick I think…

I’m not so sure too to with Zigbee binding. But at least zbbridge with tasmota firmware we can extend the range of Zigbee device connection. There is no need to stick with my RPi. That is the most advantage for me.

and I’ve seen from many people experience that zbbridge + tasmota is easier to implement with zigbee device than zigbee2mqtt + C2531 usb stick.

Yes, absolutely agree!

So back to the issue: this is going to be very difficult to diagnose remotely, especially as most here have no experience: again, head on over to the Tasmota Discord channel for help!

Note: to increase range of your CC2531, plug it into your Pi through a USB extender cable so that it can sit further away from your Pi: I’ve had good results with this method!

1 Like

That is what i do with my Z-Wave stick. The server is located in the bottom of a metal rack & the stick is on an extension strapped to some network cables.

After asking help from tasmota discord channel. They told me to change to “better CH340G usb ttl”

Then I decide to order these module

Let’s see if the new “better CH340G” and FT232RL can work. :grin:

I interest in zwave but the zwave device is not easy to find around my location (I found only Fiboro that I can buy around here and it’s very expensive.

But still. zwave is in my plan to do the next trial after If I success with zigbee

I had this problem with my kettle and others have had the same problem with the ifan03

The issue is that you are connecting to an already used serial line and trying to communicate on it.

The ZigBee chip is connected to those tx and rx lines that you also have to connect too. A better ttl programmer may drown out the ZigBee chip and may work.

The safest is to remove the ZigBee chip and replace once flashed with tasmota or short it out and program it before you break something.

You could try and connect zreset and gnd to stop the zigbee chip from trying to talk

The problem already solve after use new FTDI Programer for flashing. Thanks everyone!

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.