Problem with openHAB App for Android

  • Platform information: Android
    • Hardware: _Huawei P20
    • OS: Android 10
    • openHAB version: OH 2.5.12
  • Issue of the topic: Problem with the Android App on me Huawei.

At first, i say sorry for my bad english. But i hope i could exlpain you my Problem.
I used openHAB since 3 years and since 2 years i used the couldconnector and the openHAB App for Android. I used the App on two devices, a tablet from Archos and my Huawei Smartphone,the system is running beautyfull so far.
I beleave since last update only my tablet works fine, my Cellphone show me a mistake:
“can’t find a openhab server in your network” Go to Settings or start demo mode.
I take the same Input for Server,username and Password on my tablet and it works fine.

I think that the App connected to, because i saw the name of my Cellphone an in the App the signs on the left Side show green an say connected.

But unfortently the App on my cellphone say no openHAB server in your network so it can’t connect over cloudconnector or direkt in my wlan.

Have you any idea what i did wrong or who too solve this issue
Many thanks

Hello Micheal :slight_smile:

so you are entering the exact same IP or hostname in the url-field right?
Please try to reach your openHAB instance from your browser e.g. openhab:8080 to see if your phone can reach it.

  • If this works there might be a problem with the app worth investigating. If so I’d recommend opening an issue on Github.
  • If this doesn’t work it’s not the fault of the openHAB App but instead an issue of your network configuration.

  • Did the openHAB work before for you on your phone?
  • Which version is not working? Which is?
  • Please share your app log. For this open the app, go to Settings => View log and insert the log here. You have to do add is as a file since the log is probably to long



Hello Felix,

thx for your fast answer. I could try the openhab over the webbrowser of my phone.
Yes it is right before updating the App had no issue and i could use her. the same App on my tablet had no problems only my cellphone.
And yes i used the same data for tablet and cellphone, befor update i could use twice, after it works only on my tablet fine.
How could i send you the protocol it is on my Cellphone an i wrote about my PC? Did you have a Idea for me?


I can’t make a upload, because new useri can`t upload files. :-((((


And what’s the result of this?

Upload it on GDrive, Dropbox or any other cloud service you use and share us a link

Hello Felix,
not that we misunderstand each other, it’s about the Android app from Openhab, everything else works fine and is not the problem. Until the update, I had access to my sitemap both on my mobile phone and on my tablet. After the update, I can still access the sitemap with the tablet and the app, only the mobile phone cannot, although all settings are identical to the tablet. And it can neither access my network nor from outside. i hope you can understand? Furthermore, I don’t use the cloud except for the Google Drive. I am a layman. Thank you for your support

If this is the case this is not a problem of the app! If your phone can’t reach your server the app can’t work since it cannot communicate with the server.
This is a problem of you network configuration

ok but why it works fine with the tablet??? So if it was a problem with the network i should have the same problems with my tablet, but that works fine.
the tablet works with Android 6.0
the Cellphone with Android 10.

I don’t know…
I don’t know what router you are using. I don’t know what Access Points you are using. I don’t know if you have so VLANs set up. I don’t know if your router has some weird firewalls. → I don’t know your network configuration.

If your phone can’t reach your openHAB instance this is not a problem of the openHAB app or of openHAB itself. Your phone has to be able to communicate with your server and while this is not the case we can’t help you. Please ask your ISP, network administrator or friend who knows this stuff.

ok thx for answer i would do, and i reported to you if i had new information
thx a lot

It’s strange that the app won’t connect to myopenhab. This suggests to me that your phone is the problem. Are you running any apps/settings that limit Internet access for other apps? That would potentially interfere with the openHAB connecting to myopenhab.

When you’re on your Wifi, have you tried using the IP address of your openHAB server (e.g. to see if that works? Host names tend to be unreliable with Android devices, and it’s possible that for some reason your P20 just can’t find the right host name in the routing table.

If this doesn’t work, I suggest uninstalling the app and reinstalling it so that it will auto-discover your local server. You can also try the “openHAB Beta” app, which you can install at the same time as the regular openHAB app.

Hello, I’ll get in touch again.
I found and solved the problem together with a friend. He is a systems engineer and helped me implement the suggestions in this threat. First of all, it is not a network problem as expected, since all devices can be pinged.
It’s ultimately an Android 10.0 problem.
You have to go to Settings-Apps-Apps-openhab-storage.
There you delete the data and the cache.
Then start the Openhab app, enter your login details again and everything goes perfectly.
The Archos tablet uses Android 6.0, so this function is not available.
Thank you for your help and this for information for everyone who might have problems with it.
best regards

1 Like