Problem with schedule CET and UTC

  • Platform information:
    • Hardware: Raspberry PI 4_
    • Java Runtime Environment: openjdk version “11.0.12” 2021-07-20
    • openHAB version: OH3.1 stable

Actual I have the problem that my scheduled tasks are one hour delayed. It looks for me like a problem with the UTC and CET timezones.

But schedule in OH 3 shows (tasks in the past will not be showed)
hardcopy from the same time like the first about system time

has someone na idea what I forget.

Many thanks

I do see the same, however IMHO this is a problem only on the Schedule page.
My rules are running at the expected times, however the Schedule page seems to show all the coming events as if the system would be running on UTC.

Haven’t used it before.
How did you set the schedule ?
I just set them via web browser to 9:00 ( CET ) at at fixed time of day.
Checking the schedule again it shows 9:00 ( CET ).

I’m using cron jobs, they all relate to CET and run on the expected CET.

Hi all,
many thanks for your remarks and hints.

And yes, I tried to used the integrated functionality in OH3 to schedule rules. In the past I done it in a rule itself, time as event and this works well. I agree with opus, it looks like that schedule used another timezone - from where no clue. System itself is Europe/Berlin, OH is Europe/Berlin and Java too. There is no posibility to say UTC or CET. That can be only the reason why I have 1 hour difference in the schedule function to the real time / system time.

For me it looks like I can’t use this and must go back to the rules solution - this works without problems.

@Wolfgang, I never useed it before. How see my remarks.

The schedule task looks

I wondering because it looks like a normal cron task

I have made now a lot of change which I found. Set cron from UTC to CET, change location in OH3 to none, then system time will be used. But al without any result.

I guess that here UTC is hard coded implemented and thats the problem - all other are focused on CET. No other explaination I doesn’t have.

I let this topic open because solved it isn’t but hope that someone has an idea later on. I guess we need support of the developer of the schedule panell.

That is strange as far as I understand I did the same setup of the schedule e.g. via browser and the relatd code is:

  - id: "1"
      cronExpression: 0 0/5 14 * * ? *
    type: timer.GenericCronTrigger
conditions: []
  - inputs: {}
    id: "2"
      text: bla
    type: media.SayAction

So it should run every 5 minutes between 14:00 and 14:59. Which it seem to do:

fgrep bla /var/log/openhab/openhab.log

2021-11-30 14:50:00.043 [WARN ] [core.voice.internal.VoiceManagerImpl] - Error saying 'bla': No TTS service can be found for voice null
2021-11-30 14:55:00.042 [WARN ] [core.voice.internal.VoiceManagerImpl] - Error saying 'bla': No TTS service can be found for voice null

and it is also displayed so:

I am also in CET timezone, Germany. The only thing that may be different is that I am using english language settings.

EDITed: this is OH 3.1.0-1

Yes and No, the interesting thing is, that you schedule the bla task I guess at aprox 14:46 o’clock. Normally the schedule overview shows only tasks in the future. Then the overview would start with first next task at 15:00 o’clock but you can see in your overview it starts at 14:00 a’clock - if I have a task which comes up every 5 mins or in a definied time interval it isn’t a “real” problem. Actual I have a switch which switch on at 5 in the morning but it switch at 6 - that’s the reason why I recognized it. All other things like Time Display, logs,… are ok, only the schedule pages has this problem.

But I will make some more tests. Tomorow morning I know more. I have schduled it now for 4 o’clock and hope it works at 5.

Another trial: Yesterday evening before 22:00 CET I created a new schedule.
Starts at 02:00 in the morning and repeats every 5 hours.
That is also ok. I used repeated schedule because your first screenshot also shows them.
Is this wrong understand and the problem at your site is only with a daily repeated schedule ?

I think this boils down to a minor UI issue. The events are executed correctly, but the schedule page displays events that are in the past (e.g your 7:00 event is displayed even though that time has passed already, your screenshot was taken 7:40 according to the file name)

that is correct

I agree, thats a minor issue. "The events are executed correctly, but the schedule page displays events that are in the past " - > yeah, in the first moment I thought the time is wrong because the executions was also 1 hour delayed but after reset the cron job and reload the schedules it works correctly. No clue why …

Many thanks for your response and support,