Problem with setting up Zooz USB Z-Wave Plus S2 Stick ZST10

I suppose you could try starting openHAB as root. While you wouldn’t want to leave it this way, it might rule out any permission issues with the serial port. Be careful, though, as it may result in some openHAB files being owned by root (e.g. log files), so you’ll need to fix any file permission issues after you’ve tried this.

I have to second this recommendation. Part of the Openhabian installation options is a global permissions fix.

Only random suggestion at this point, as I do not have your setup, and this may not be an issue, but since the focus is on permissions, there have been forum posts over the years about the LCK file needing to be with openhab owner.


Hi @stefan.oh

Thank you for confirming this and all the others. Pretty much as I thought.

Keeping it away from the PC with an extension cable or using a USB2 port might help. I’ll try that later today.

Stay tuned, however, to my upcoming response to @robmac to see what interesting things I learned yesterday evening.

Hi @robmac

Thanks much for your ideas!

Soooo… While waiting on responses here, I had reached out to the hardware vendor (Zooz) and they immediately suggested the same thing as you (i.e. Simplicity Studio). They also sent me relevant Windows USB drivers and updated firmware for the stick. [Alas, now they are AWOL with no responses to further detailed queries. ]

I installed Simplicity Studio (into a Windows Virtualbox VM) yesterday – but guess what? Stick not recognized by the app. [ Meanwhile, Windows “dings” when it is inserted AND device manager shows it as available on COM8! ]

Frustrated, I quickly installed HomeAssistant into a VM. Magic result! The Zooz stick can communicate with the few Z-Wave devices in this house.

Problem is, I do NOT want HomeAssistant. OpenHAB looks far more enticing for a number of reasons, including ease of installing as a service on the existing operating system and NOT needing a dedicated (even though it would be lightweight) PC or VM . . .

If anyone has any ideas on how to proceed now that I have identified the hardware works correctly in HomeAssistant, I would appreciate it

Hi @apella12

As I mentioned to @robmac, I have zero interest in running a completely separate instance when I have an underutilized, powerful server sitting here. [ I would consider OpenHabian in a VM for testing purposes, of course, as I did with HomeAssistant yesterday. ]

I do think that the stick merely needs to be reset somehow. The problem at the moment is: the hardware is not cooperating (not recognized) with the utility the vendor has recommended.

Take a look at my “result” in Simplicity Studio when I tried to recognize the stick in order to install the “PC Controller” plugin . . .

The hardware is fine which is good.

As lsusb reports your zooz as Aeotec I assume it is just a badged version of the aeotec. This thread might help.

the solutions are documented here [SOLVED] OH3: zwave binding Z-Wave Serial Controller Aeotec Z-Stick Gen5 remains offline - #39 by HaKuNa

The serial handling is part of core so setting it to debug might help.
log:set DEBUG

Zooz appears to rebrand a few devices from other manufacturers but it might still not be identical so the thread might not help.

No worries. Missed your response to Rob. When I started a few years ago I was drawn to the openhabian promise of open-source home automation without being a linux expert. Turns out it is very helpful to be at least a linux novice.

Your screen shot doesn’t look right, but I’m not an expert on the program. It has been awhile, but I do not recall having to add the tools. This is what I get when I open Simplicity Studio.


edit: Here is a link that might help

Hi @apella12

Well, there’s my problem! I have been using Linux in one form or another for over ten years. I can therefore probably no longer be considered a “Linux novice” . . . even though I sometimes still forget about checking permissions! :grimacing: [ Fortunately not in this thread. ]

Perhaps if I were a novice, I would not overthink this and just buy a Hubitat hub! :upside_down_face:

My screen shot comes AFTER asking Simplicity Studio to install plugins. At the bottom of your “tools” screenshot you will notice “Add/Remove Tools” I have the same window, but it is empty . . . at which point I try to add tools, leading to the screenshot I posted.

Hi @robmac

Thanks for pointing out the thread. I’ll digest in a moment . . .

A moment ago I took apart the Zooz stick. Here’s a closeup of the physical device, perhaps it will give someone an idea as to whether it is indeed a Zooz device or an Aeotec one . . .

I think both. The zooz-z-wave-plus-s2-rgbw-dimmer-for-led-strips is built by fibaro and is basically same as Fibaro rgbw 2.
you can see they do not hide it even on the product photo ZOOZ ZEN31 RGBW DIMMER – ZOOZ

I just ran lsusb on my server, and my Zooz S2 also reports as an Aeotec.

Bus 001 Device 004: ID 0658:0200 Sigma Designs, Inc. Aeotec Z-Stick Gen5 (ZW090) - UZB

@FBachofner, do you have a Raspberry Pi laying around? For testing purposes, I’d be curious if the stick would work with openHABian on it.

1 Like

So I hit the add/remove tools and get

Then I hit package manager & navigate to the tools tab

Are you signed in? All this is without the controller being plugged into the pc.


Hi Bob @apella12 Thanks!

It turns out Zooz sent me the (standalone) “PC Controller” package by e-mail right before lunch. I ran that completely independently of Simplicity Studio and while the PC Controller software is able to run, it was not able to update the firmware as I got blocked at step 6 of Zooz’s firmware update instructions – the device can not get “added” in they way they suggest.

See attached screenshot

After lunch I removed, reset, etc. everything I could between the slaves and the controller (let’s hope that doesn’t turn out to have been a bad decision! :crazy_face: )

Now I seem to be able to do even less with the provided “PC Controller” software (including “re”-adding the Zooz stick)

I am again waiting on hearing from the company for advice on bending their controller to my will.

BTW: yes, I was logged in to Simplicity Studio, but I had the stick plugged in. Perhaps that is why I did not see the package manager (I had only device and product group options).

BTW#2: your Simplicity Studio looks quite different than mine. Looks like you are running on Linux (I am/was on Win 10 in a VM as they – Zooz et al – seem to prefer that. Only Ubuntu is “supported” in Linux and I am mostly working on new Fedora installs here. I don’t want them to claim it is not working because of platform issues.

Hi @rpwong:

Thanks for checking on your similar (likely “same”) hardware. Good to get confirmation on this.

I don’t have a Pi around. Not only am I a fan of Odroid (over Pi), but I am trying to do all this home automation for my octagenarian Mom and am thus 300 miles away from my handful of single-board machines . . .

I might install openHABian in a VM later today to check.

I’m hoping Zooz will call me so I don’t have to go through 20 permutations in back-and-forth e-mails.

Hi Russ:

Curious: are you on openHAB 2.x or 3.x?

OH 3.2, but I’ve had my Zooz stick since OH 2.4. Shouldn’t make a difference.

I’m not sure that will prove anything, because it’ll still be attached to the same computer. I’m wondering how it’ll respond on a completely different system.

This is going to sound really basic, but have you tried deleting the Z-Wave controller thing from openHAB and then adding a new one? I have no reason to think that there’s a problem with the thing, but it just doesn’t make sense that other software can access the controller and OH can’t at the same /dev/ttyACM0 port.

Hi Russ @rpwong

Do you have anything in /etc/udev related to the Zooz S2?

I am reading the thread: [SOLVED] OH3: zwave binding Z-Wave Serial Controller Aeotec Z-Stick Gen5 remains offline - #4 by hmerk recommended by @robmac

That thread indicates the stick in question has the file /etc/udev/99-usb-serial.rules My install has nothing in udev . . .

Bad Felix! I am just noticing OH Prerequisites

Can someone weigh in on how likely my problem might stem from using OpenJDK instead of AdoptOpenJDK ?! I know virtually nothing about Java and am a bit surprised that OH seems to care about this so specifically.

The more likely issue seems to be the potentially “missing” file at /etc/udev/ – but this has not yet been answered.

I don’t think that has anything to do with this. Have you tried the solutions from Rob’s link to that thread?

I feel like that should be where you start. Scanning the thread, there are a few other things mentioned later on, since the post is quite old.

I don’t know anything about Java either, so I can’t comment on that.

Hi Russ @rpwong:

Except that udev rules help keep device names as you want them and also static, if desired. A little corner of my brain thinks UDEV rules could somehow be leveraged to bend this USB stick to my will.

Will be working through the ideas this evening.

Curious: What OS platform are you on? What Java version are you using? (in Linux terminal: java -version )?