Problem with Tado Binding

Hello,

i installed the tado-binding (copied it to addons folder an created the .things, .items etc. as discribed in github), but alway get the following error in the openhab.log. Also the tado-thing is not shown in the thing-list in paperui.

ERROR - org.openhab.binding.tado

org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.tado [228]
Unresolved requirement: Import-Package: com.google.gson; version=“2.5.0”

at org.eclipse.osgi.container.Module.start(Module.java:434)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1562)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)[org.eclipse.osgi-3.10.101.v20150820-1432.jar:]

2017-03-16 20:25:11.413 [WARN ] [ome.core.thing.internal.ThingManager] - Cannot delegate update ‘56.00’ for item ‘Humidity’ to handler for channel ‘tado:thermostat:home:humidity’, because no thing with the UID ‘tado:thermostat:home’ could be found.

Can you help me to get this binding running?

Thanks a lot!

nobody an idea or do you need more informations?

i am really wondering, that there is that less interesting in that binding. in generel the tado thermostats work very well an have the nicest design of all the thermostats on the market. so its really a pity, that the binding doenst work…

i would be very happe if someones out there who could help solving this problem… i would also be interessed in knowing, if others are using this binding and if the mistake is on side or if something is wrong with the binding…

I am so close to buying Tado myself, but this topic - or the lack of replies - made me a little worried about doing so. :sweat_smile:

However, the binding might have problems, have you tried to do as proposed in this topic?Openhab2 executeCommand fetch JSON string - Tado

Please let me know how it goes :slight_smile:

Buying the Tado thermostas wont be a mistake - the thermostats theirselfs work fine and with the help of ifttt you can integrate them into openhab as well (for example open door/window stops automatic mode an switches the thermostats off).

edit: i tried it out and it works! but it would be great, when it would work with the binding. i dont know how to get the informations of the differenz zones on the way with the http-binding

ok, now i am trying an trying and i got the zones-information now with this url:
https://my.tado.com/api/v2/homes/59253/zones/1/state?password=xxxxx&username=xxxxx

(more informations see here: http://blog.scphillips.com/posts/2017/01/the-tado-api-v2/ )

after the url-call i get this information back:

{"tadoMode":"HOME","geolocationOverride":false,"geolocationOverrideDisableTime":null,"preparation":null,"setting":{"type":"HEATING","power":"ON","temperature":{"celsius":18.00,"fahrenheit":64.40}},"overlayType":null,"overlay":null,"openWindow":null,"link":{"state":"ONLINE"},"activityDataPoints":{"heatingPower":{"type":"PERCENTAGE","percentage":0.00,"timestamp":"2017-05-01T12:39:30.069Z"}},"sensorDataPoints":{"insideTemperature":{"celsius":20.39,"fahrenheit":68.70,"timestamp":"2017-05-01T12:39:12.437Z","type":"TEMPERATURE","precision":{"celsius":1.0,"fahrenheit":1.0}},"humidity":{"type":"PERCENTAGE","percentage":51.70,"timestamp":"2017-05-01T12:39:12.437Z"}}}

so how can in call the right informations now? getting the home-status is no problem, it works with the following item-description, but how do i catch the inside-temperature etc.?

String tado_wohnzimmer_Mode "Mode [%s]" { http="<[tado_wohnzimmer:60000:JSONPATH($.tadoMode)]" }
Number tado_wohnzimmer_Temp "Temp [%.1f °C]" { http="<[tado_wohnzimmer:60000:JSONPATH($.insideTemperature)]" }

ok, i got it.... the item-configuration has to look like this:

String tado_wohnzimmer_Mode “Mode [%s]” { http="<[tado_wohnzimmer:60000:JSONPATH($.tadoMode)]" }
Number tado_wohnzimmer_Temp “Temp [%.1f °C]” { http="<[tado_wohnzimmer:60000:JSONPATH($.sensorDataPoints.insideTemperature.celsius)]" }
Number tado_wohnzimmer_SetTemp “SetTemp [%.1f °C]” { http="<[tado_wohnzimmer:60000:JSONPATH($.setting.temperature.celsius)]" }
Number tado_wohnzimmer_Humidity “Humidity” { http="<[tado_wohnzimmer:60000:JSONPATH($.sensorDataPoints.humidity.percentage)]" }
Number tado_wohnzimmer_HeatingPower “Heating Power” { http="<[tado_wohnzimmer:60000:JSONPATH($.activityDataPoints.heatingPower.percentage)]" }


My widget now got all the values… and i think i go and add the heating power…

1 Like

Great work getting it going. Your not able to set the heat directly from OpenHab stil?
I’m thinking about using HomeKit Integration to do mediate that issue insted of ifttt since I’m already familiar with it.

What is meant by Heating Power? :slight_smile:

thanks. i didnt try it, yet and honestly dont know how to send a command to the api… but i think there should be a possibility because you can control the heating over the web-interface of tado as well… if you (or somebody else) can tell me what to do and how to generate and send the specific url to the api, please let me know…

maybe there is somebody, who could bring the code and the urls into a new or an update of the tado-binding. i also would be interested in learning how to do that…

Heating Power means the state if tado is heating or not… but i am not sure, how presice the value really is… for excample i got 100% yesterday in the bathroom but the heating itself didnt hat the max temperature…

nevertheless i updated my widget… a few things a still to do… NULL means here that the thermostat ist turned off manually.

Poking around on Google i found this post, and apparently there is a way to send commands using Curl PUT, take a look at http://blog.scphillips.com/posts/2017/01/the-tado-api-v2/ :slight_smile:

Heating Power means the state if tado is heating or not… but i am not sure, how presice the value really is… for excample i got 100% yesterday in the bathroom but the heating itself didnt hat the max temperature…

I see… maybe you can confirm something, I read somewhere that somebody suspected that Tado might only set the heating power to either 0% or 100% - not something like 50% or so. I’m not sure how much difference this does.
(My heading bill is decided by some sort of “magic” vapor-liguid on the side of the radiator, where a 50% power over a longer periode, might make a diffrens over 100% short time)

the description of the api i found already… but i am not so deep into working with it… for example i dont know how to send the put-command and how to configure the item in openhab… do i need an extra item for reading the value and another one to send a new value or can i combine it?

I dont have that much experience with it either, but I think you can SSH into your OpenHAB machine and try the curl command directly in bash - I think I did this at one point with something else.
I think you might need a (relativ) simple script behind a setpoint item, but i’m not sure. You might be able to combine the setpoint item script so that it can both read and write the temp.

For anyonye else who is looking for a way to integrate Tado into Openhab:

EDIT: [DISCONTINUED] Tado Binding. Enjoy, Tado Users! :slight_smile:

Cheers

3 Likes