Problems adding items to a group

i tried to configure several groups each containing some items. Some groups are working, other don’t (they are all configured in the same way…). Looking in the karaf console, some groups show Members > 0 (fine), other show up with Members=0. Has anyone an idea?


If you post the Groups/Item definitions that would help to diagnose the problem(s)…

here it is:

Group gTemp
Group gHell

Number Temperatur “Temperatur Süd [%.1f °C]” (gTemp) { knx="<1/1/5", channel=“homematic:GATEWAY-EXTRAS-8C7D047F:8c7d047f:GWE00000000:1#KNX_Temperatur” }
Number HelligkeitOst “Helligkeit Ost [%.0f Lux]” (gHell) { knx="<1/1/1", channel=“homematic:GATEWAY-EXTRAS-8C7D047F:8c7d047f:GWE00000000:1#KNX_HelligkeitOst” }
Number HelligkeitSued “Helligkeit Sued [%.0f Lux]” (gHell) { knx="<1/1/2", channel=“homematic:GATEWAY-EXTRAS-8C7D047F:8c7d047f:GWE00000000:1#KNX_HelligkeitSued” }

The group gTemp works fine, the other one doesn’t work.


Odd. Looks OK to me…in karaf, when you do:
smarthome:status HelligkeitOst
smarthome:status HelligkeitSued
are the items shown ?

yes, they are shown correctly. And they are working fine (each individually).

Lost…I would try to simplify:

Remove the [%.0f Lux] and the whole part in brackets {}, then reload items file.
If OK then, re-add removed parts one by one.
Not a real “solution” but maybe it will help to pinpoint the problem…

I tried the followong steps:

  1. Removed […] and {…} --> no effect, means Members=0
  2. additionally removed “” --> Members=2
  3. then i added again all the information --> Members=4 !

now both items are twice in the group (easy to see when drawing a chart)
i have no idea about the reason for that…

I made another try: only removing the “<…>” --> then the item was added to the group successfully, but also doubled after inserting “<…>” again

Are you on OH2?
If yes, can you try to restart oh to make it work?
Means, item missing but seems to be configured correctly. Stop openhab and start again. Is the group populated correctly now?
This was mu observations till now. Haven’t found the culprit though.

After the restart of OH2 all the groups are populated correctly.

Hard to understand, but it is a workaround how it works.

Thanks a lot.

I have the feeling this might be a bug in OH2. I just stumbled upon not updating active groups. Might be related. I always have to restart OH after changing the config to make it work again.