Problems connecting "Owntracks OSM" on Galaxy Watch to

Has anyone had any luck connecting a Samsung Galaxy Watch to using the “Owntracks OSM” app.

I can happily connect using the Owntracks Android app so everything in myopenhab is ok, but the watch version - which purports to provide the same functionality - fails.

Logging starts with errors such as "Failed to construct “‘Websocket’: The URL ‘ws://[]:x883/mqtt’ is invalid” I’ve tried on both 1883 and 8883. There is little no place to alter the URL that the app generates.

Does this mean I’m out of luck - the app worn’t work with myopenhab?

Set up the Android app how? Particularly set up to use HTTPS or set up to use MQTT? This is important because the watch app is attempting to connect to an MQTT broker which won’t work through

And the error is also pointing out that even if you were using MQTT and it were possible to do MQTT through, it still wouldn’t work becuase x883 isn’t a valid port number.

It looks a lot like you need to review the configuration on the watch app and make sure everything is the same as your Android app.

Thanks for replying - you’ve answered my Q by saying that won’t answer MQTT - the watch app only seems to allow this.

I’ve tried on port 8883 and 1883 as I’ve seen them both suggested, and x883 was my clumsy shorthand… :wink: