Problems upgrading OSX install

Hi all,

Just wondering if anyone can help me here. I decided to download the latest stable release and to replace my snapshot from last December (!).

I did my “usual” approach:

  • backup existing openhab (mv openhab openhab_30052017)
  • in the new openhab directory, replace conf with openhab_30052017/
  • this time I did the same for userdata, since I understand this has conf data too now (and I didn’t want to wait for all my zwave devices to be discovered again).

Initially it failed because of an apparent permissions issue (at least, after chown -r it got further)

Now it fails with:

Could not resolve mvn:org.eclipse.birt.runtime/org.eclipse.osgi/3.10.2.v20150203-1939

This seems to be related to my copying the old userdata directory - at least, replacing it with the blank userdata fixes that problem, though then I get:

java.lang.NoClassDefFoundError: io/netty/util/concurrent/DefaultPromise$2
at io.netty.util.concurrent.DefaultPromise.notifyListeners(
at io.netty.util.concurrent.DefaultPromise.setSuccess(
at io.netty.util.concurrent.SingleThreadEventExecutor$
at io.netty.util.concurrent.DefaultThreadFactory$

How are we supposed to do this? Is it documented anywhere?


i managed my updates with my following script. This is for linux, but i think it should work similar:

/bin/rm -R /home/user/openhab/runtime_$(date +%Y%m%d)/
/bin/mkdir /home/user/openhab/runtime_$(date +%Y%m%d)/
/usr/bin/wget -P /home/user/openhab/runtime_$(date +%Y%m%d)/
/bin/mv /home/user/openhab/runtime_$(date +%Y%m%d)/download_file? /home/user/openhab/runtime_$(date +%Y%m%d)/
/usr/bin/unzip /home/user/openhab/runtime_$(date +%Y%m%d)/ -d /home/user/openhab/runtime_$(date +%Y%m%d)/
/bin/rm /home/user/openhab/runtime_$(date +%Y%m%d)/
/usr/bin/rsync -a --exclude /logs/ --exclude /log/ --exclude /tmp/ --exclude /cache/ --exclude /etc/ /home/user/openhab/runtime/userdata/ /home/user/openhab/runtime_$(date +%Y%m%d)/userdata/
/bin/cp -n /home/user/openhab/runtime/userdata/etc/* /home/user/openhab/runtime_$(date +%Y%m%d)/userdata/etc/
/usr/bin/rsync -a /home/user/openhab/runtime/conf/ /home/user/openhab/runtime_$(date +%Y%m%d)/conf/
/usr/bin/wget -P /home/user/openhab/runtime_$(date +%Y%m%d)/addons/
/bin/chown -R user:root /home/user/openhab/runtime_$(date +%Y%m%d)/

As you can see there, i don’t simly sync the whole userdata folder because i had similar issues. I exclude many folders (logs, log, tmp, cache etc) and copy the /userdata/etc folder without! overwriting. That solved the issues i had when i updated from an older version to 2.0 stable.

Thanks! That seems to have fixed the crashes. Unfortunately zwave still isn’t working because

Status: OFFLINE - COMMUNICATION_ERROR Serial Error: Port /dev/tty.SLAB_USBtoUART is in use

Which is very hard to understand as

mac-mini:~ security$ lsof | grep *SLAB_USBtoUART*

returns’ nothing, and I see only one open instance of openhab.

I’ve rebooted multiple times, without success. :frowning:

I guess next is to just try a clean install and see if I can get this working first.

Still not working:

20:01:09.866 [INFO ] [smarthome.event.ThingAddedEvent ] - Thing 'zwave:serial_zstick:157b8d41438' has been added. 20:01:09.934 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'zwave:serial_zstick:157b8d41438' changed from UNINITIALIZED to INITIALIZING 20:01:09.986 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Connecting to serial port '/dev/tty.SLAB_USBtoUART' 20:01:09.990 [INFO ] [smarthome.event.ThingUpdatedEvent ] - Thing 'zwave:serial_zstick:157b8d41438' has been updated. 20:01:10.011 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'zwave:serial_zstick:157b8d41438' changed from INITIALIZING to OFFLINE (BRIDGE_OFFLINE): Controller is offline 20:01:10.082 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'zwave:serial_zstick:157b8d41438' changed from OFFLINE (BRIDGE_OFFLINE): Controller is offline to OFFLINE (COMMUNICATION_ERROR): Serial Error: Unsupported operation on port /dev/tty.SLAB_USBtoUART

Very weird. I might just revert back to the previous version for the moment.

I don’t have OSX, but in linux the only thing that can go wrong here are permissions. Does the user, that runs openhab have enough rights to access that usb stick?

Yeah it’s root (since I’m running it as a service). Linux and OSX are pretty similar.

It’s not impossible that there’s a hardware issue - I had the electrician in disconnecting stuff, so I probably need to go and check. It’ll be a few days unfortunately.