Problems with accessing files after OH2 crash

Hi,

I try to bring up my OpenHab2 environment and struggle with a lot of things.
After I mad it to install all related files and tools to handle my Homatic devices I though I’m trough the pain.

But look like I’m wrong.
In the meanwhile I added 9 Homatic device in several rooms. I use a CUL and Homegear for communication.

Kitchen and livingroom worked fine and with changing temperature and sending Telegram Messages in case of an event.

I started to add the GuestBathroom and after adding the window contact the system crashed.
After a reboot the whole Things list was gone and the controle environment was emty.

I fixed this by restoring tiles from the Backup folder all devices are back.
I continued my work, created items and rules and everything looked nice.

But after a reboot all changes were gone and I ended up at the point I used the receoved files.

Following message I can see in the Log:
2018-01-01 14:09:41.573 [ERROR] [me.storage.json.internal.JsonStorage] - Error writing JsonDB to /var/lib/openhab2/jsondb/org.eclipse.smarthome.core.thing.Thing.json. Cause /var/lib/openhab2/jsondb/org.eclipse.smarthome.core.thing.Thing.json (Permission denied).

I guess it’s a problem with acesss rights but I’m to frustrated with OpenHab2 (even FHEM was not easy to handle, it worked) to figure it out, I need a break.

Would be great If somebody could help me out here otherwise I delete OH2 and stop wasing my time with it.

Thanks Best regards,

CH

I changed the rigths now and gave permission 0#666 which solved the first problem.

Now I can see following:
An error occurred during the script execution: Could not invoke method: org.eclipse.smarthome.model.script.actions.BusEvent.sendCommand(org.eclipse.smarthome.core.items.Item,java.lang.String) on instance: null

It’s a bit strange becasue yesterday the rule and the item worked fine.

Item:
Number StoreTempWohnzimmer “Temperaturspeicher [%.1f °C]” (Temperatur) //Temperaturspeicher

Rule:

//
/* variable declarations */
/
/
var Number LowerTemp = 14.0 // Abgesenkte Temperatur

//
/
rules /
/
/

/Regelung Fensterkontakt aktiv/
rule "Heizung_Wohnzimmer_Fensterregelung"
when
Item FensterkontaktWohnzimmerLEQ0504204_1_State changed

then
if (FensterkontaktWohnzimmerLEQ0504204_1_State.state.toString == “OPEN”) {

	StoreTempWohnzimmer.sendCommand(WandthermostatWohnzimmerLEQ0080316_2_SetTemperature.state)
	WandthermostatWohnzimmerLEQ0080316_2_SetTemperature.sendCommand(LowerTemp)
	sendTelegram("bot1OpenHab2", "Fenster Wohnzimmer geöffnet! Temepratur auf %.1f gesenkt.",LowerTemp)

    } else if (FensterkontaktWohnzimmerLEQ0504204_1_State.state.toString == "CLOSED") {

    WandthermostatWohnzimmerLEQ0080316_2_SetTemperature.sendCommand(StoreTempWohnzimmer.state) 
	sendTelegram("bot1OpenHab2", "Fenster Wohnzimmer geschlossen! Temepratur auf Ausgangswert erhöht.")

    }     

end

Any idea what’s the problem?

Thanks for help!

BR

CH

I fixed it by my own.

Looks like the TempStore Items were not present anymore. I realized it as I tried to delete the values from the ITems list.
Got ERROR 404.

Another reason could be that the Items were not initialized, so I used now in my rule the as DecimalType.

It’s not clear to me why the rules worked before without this, but maybe the Items were initilized and worked till the crash happend.

For now it looks like it works.

Hope the best that nor crash happens anymore.

BR

CH