Problems with accessing OpenHab Dashboard

  • Platform information:
    • Hardware: _Pi4
    • OS: _what OS is used and which version
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version: Later version
  • Issue of the topic: please be detailed explaining your issue. Can’t access OpenHab dashboard after an extended time of inactivity due to other priorities. It was always very stable before this. I am using my browser that always worked using http://192.168.0.101:8080/start/index. Tried http://openhab:8080 and http://192.168.0.101:8080. To my best knowledge, the ip address is correct since it responds to a ping is the only device listed on my Moden device list not accounted for. Any ideas?
  • Please post configurations (if applicable):
    • Items configuration related to the issue
    • Sitemap configuration related to the issue
    • Rules code related to the issue
    • Services configuration related to the issue
  • If logs where generated please post these here using code fences:

Have you recently done any change ?
Did you try to reboot the system - wait for about 20 to 40 minutes and then try to access the dashboard ?
What is the content of the openhab.log file ?
What is the message in the browser ?

1 Like

Purchased a new computer, but the original computer did not work also.
I rebutted the system.
I will get you the log file now that I have connected the computer and Ras to the same 4 channel modem.
I think I am making progress and will post when I have more details.

Thanks
Jim

My problem was in identifying the openHAB ip address. Used an old Linksys modem with the carrier disabled, and it displayed the Client Hostname, ip address, and mac address. See below:

I needed to dig into the two computers connected to the Linksys Wify in order to get their respective MACs. They are as follows:
Samsung WIFI; 04-6C-59-92-DE-CA
openHAB ethernet: DC-A6-32-6F-94-22
Asus Ethernet: D8-50-E6-01-EB-E3
Asus LAN adapter Wifi: 0C-8B-FD-4C-C2-F5
Linksys Wifi: 00-06-25-91-E2-09

With these MACs i can identify the IP address and have these written down. This was allot of work. Is there a better way? Can you make a recommendation on an IP network scanner?I have used.

Thanks
Jim

as long as the name resolution in your network works you can execute:

nslookup openhab

have a look at nmap. It is available via package management in most linux distributions. A windows version is available via the download page.

So you were initially trying to connect to 192.168.0.101 when the server was on 192.168.1.101.

Thanks Bruce

Ultimately, I wanted to connect my PI to my home Mediacom router but could not find the IP address because the name openHab there was missing from the list. I was able to get the MAC address of the PI by attaching the ethernet Pi to the old 4 port router and connecting my ethernet computer browser to the router. The router table had the openHAB name so I coppeid its MAC address. I used the MAC to identify the IP address when the PI was connected to the Mediacom router via ethernet.

The IP was 192.168.0.167 and I names the no name on the local network page.name of the device. I also got the MAC address for various ports on my two computers and did the same for thiem so I knew what I had connected in the future.

I was hopeing that there is a wifi network scanner that displays the device names. I have tried 3 or 4 but failied. Can you recommend a good wifi network scanner?

Hope this makes sense.
Thanks
Jim

Dns was designed to translate names into up addresses. Some home routers that act as dhcp servers also register the names in their dns server.

I still would recommend nmap as somewhere the wifi devices are connected via wire.
To scan wifi networks you can use kismet ( https://serverfault.com/questions/469093/find-wifi-enabled-devices-stations-around ). Nevertheless for name resolution it will fallback to DNS entries.

Thanks for the insight.

My mediacom router displays all of my apple devices as generic phones and pads, and my two windows computers but not other devices. I don’t know if explains the inconsistency.

Thanks
Jim