Problems with Google's Home App not noticing Hue Emulator

Moving this question from HueEmulation and Google Home support to here by itself.

As far as I know, I have followed all of the steps in that thread, and can manually reproduce the results that are expected. i.e. I can see the proper endpoint data show up when the pairing is activated.

What I am having issues with is that when I go to Google’s home app, it goes to the screen where it expects someone to press the button on the Hue Hub, and it stays there. I have tried restarting OpenHab, restarting the pairing option, and a number of other things, but it doesn’t seem to recognize the emulator.

Has anyone had the same problem? Am I missing some weird step?

To be more specific:

  • I go to home control, and click on the +
  • I select phillips hue, and it shifts me over to a website for, and ask me to pair
  • I press “pair”, it goes to a new page with “Press the link button” and “On the Hue Bridge, press the link button to pair”

and it stays there until it times out after about 3-5 minutes.


You’re running on win7 correct?

I recall you may need to set the.listening IP address on machine with multiple IP address.
U don’t have anything complex with your IP configuration do you??

Can u run a small Linux machine and try it?

Working on setting up a linux machine… however, I do have a SSDP listener for another project that I worked on, and here is what it is seeing:

[2017-02-03 08:23:02 -08:00][Trace][S:Symphony.DlnaDeviceDiscovery][E:][P:11044][T:12276]TCD: M-SEARCH, From:
[2017-02-03 08:23:02 -08:00][Trace][S:Symphony.DlnaDeviceDiscovery][E:][P:11044][T:12276]TCD: ,[HOST:],[MAN:“ssdp:discover”],[MX:1],[ST:urn:dial-multiscreen-org:service:dial:1]
[2017-02-03 08:23:03 -08:00][Trace][S:Symphony.DlnaDeviceDiscovery][E:][P:11044][T:12276]TCD: M-SEARCH, From:
[2017-02-03 08:23:03 -08:00][Trace][S:Symphony.DlnaDeviceDiscovery][E:][P:11044][T:12276]TCD: ,[HOST:],[MAN:“ssdp:discover”],[MX:1],[ST:urn:dial-multiscreen-org:service:dial:1]
[2017-02-03 08:23:03 -08:00][Trace][S:Symphony.DlnaDeviceDiscovery][E:][P:11044][T:12276]TCD: M-SEARCH, From:
[2017-02-03 08:23:03 -08:00][Trace][S:Symphony.DlnaDeviceDiscovery][E:][P:11044][T:12276]TCD: ,[HOST:],[MAN:“ssdp:discover”],[MX:1],[ST:urn:dial-multiscreen-org:service:dial:1]
[2017-02-03 08:23:04 -08:00][Trace][S:Symphony.DlnaDeviceDiscovery][E:][P:11044][T:12276]TCD: M-SEARCH, From:
[2017-02-03 08:23:04 -08:00][Trace][S:Symphony.DlnaDeviceDiscovery][E:][P:11044][T:12276]TCD: ,[HOST:],[MAN:“ssdp:discover”],[MX:1],[ST:urn:dial-multiscreen-org:service:dial:1]
[2017-02-03 08:23:05 -08:00][Trace][S:Symphony.DlnaDeviceDiscovery][E:][P:11044][T:12276]TCD: M-SEARCH, From:
[2017-02-03 08:23:05 -08:00][Trace][S:Symphony.DlnaDeviceDiscovery][E:][P:11044][T:12276]TCD: ,[HOST:],[MAN:“ssdp:discover”],[MX:1],[ST:urn:dial-multiscreen-org:service:dial:1]
[2017-02-03 08:23:38 -08:00][Trace][S:Symphony.DlnaDeviceDiscovery][E:][P:11044][T:12276]TCD: M-SEARCH, From:
[2017-02-03 08:23:38 -08:00][Trace][S:Symphony.DlnaDeviceDiscovery][E:][P:11044][T:12276]TCD: ,[HOST:],[MAN:“ssdp:discover”],[MX:2],[ST:ssdp:all]

the 2.11 address is my phone that I am trying to connect on, the 2.25 address is where the google home is.

At the very least, I think this shows that it is getting back to my open hab system. Is there some debugging I can turn on in the emulator to see if it is also getting those packets?

(cross posted with original stream)

Hope this helps figure out what the issue is.

Running Android 7 on my phone, default settings, latest update (jan 20 I believe).

Before running the pairing app on my phone from Google Home, I added this line to the logging config: = TRACE, event, osgi:*

And I see a number of devices from existing machines broadcasting and such. When I hit the pair button in the google home-> hue bridge… nothing.

However, if I go to another program, UPNPBrowser, when I hit scan, it sends out the SSDP packet right away and I can see it in the logs.

Is it possible that the hue bridge is now using some other method of communication, hence the emulator is no longer working for me?

Anyone? I am seeing other search packets from other apps on my phone, just nothing from that one.

I have tried installing and uninstalling, etc.