Problems with Innogy Binding after Livisi-Update?

Hello,
I’m new to this board, but I’ve read in it a lot the last months.
I have a RWE/Innogy/Livisi Smarthome “Solution” running with openHAB (SHC SW-Version 8.16 - 1.1.22.363; SHC HW-Version 2; openHAB Innogy-Binding Version 2.5.9).
Despite the problems of the last “few” years I was - thanks to the discussions / solutions of this board - able to build a stable system using Innogy Smarthome only with openHAB and not with the proprietary solution.

Before the last Livisi-Update I used the parameter “WebSocket idle timeout” set to 120 (every two minutes), because my SHC got “down” every few minutes and with the value 120 I got a nearly stable system. In HABPANEL I installed two “markers”, one for SHC up/down and the other for Innogy-Backend up/down (via HTTP-Binding). With these markers implemented I could differ if the SHC or the Innogy-Backend is down.
I re-authorized all well after the change to the Livisi-Authorisation-Server (with success)

Now - after the last update from Livisi a few days ago - I got the problem that the Bridge goes offline after an item was triggered via openHAB. That is independent from the trigger itself (either a rule or a button in HABPANEL or the openHAB-App). The bridge went offline and the event won’t have an effect. Then - after a few seconds - the bridge is online again and I can trigger the item manually. Then it works well.
The Innogy-Backend is up all the time and via the Livisi-App (proprietary) it will work also.

Is there anything I have done wrong or is there anybody who has the same problem? I didn’t find the symptom described somewhere else.

If you need more information, please ask me.

Many thanks,
Andi

1 Like

Because I could not find a solution myself… Also searched the forum.
Exactly the same situation.
Very strange because I cannot find out why this happens. It is nearly impossible to change temperature for the thermostates by openhab because I have to wait some time until temperature changes back to the old value or not. But you will never know if livigy received the new temperature setting or not.

From the logs… I change the bathroom and this happens then (I anonymized the IDs of the items):

2020-10-21 21:54:30.805 [ome.event.ItemCommandEvent] - Item ‘HeizkoerperthermostatBad_TargetTemperature’ received command 23.0
2020-10-21 21:54:30.835 [nt.ItemStatePredictedEvent] - HeizkoerperthermostatBad_TargetTemperature predicted to become 23.0
2020-10-21 21:54:30.851 [vent.ItemStateChangedEvent] - HeizkoerperthermostatBad_TargetTemperature changed from 23.5 to 23.0
2020-10-21 21:54:34.068 [hingStatusInfoChangedEvent] - ‘innogysmarthome:bridge:xxxxxxx’ changed from ONLINE to OFFLINE (COMMUNICATION_ERROR): java.util.concurrent.TimeoutException: Total timeout 10000 ms elapsed
2020-10-21 21:54:34.079 [hingStatusInfoChangedEvent] - ‘innogysmarthome:RST:xxxxxxx:abcdefghijklmnopqrs’ changed from ONLINE to OFFLINE (BRIDGE_OFFLINE)
2020-10-21 21:54:34.084 [hingStatusInfoChangedEvent] - ‘innogysmarthome:RST:xxxxxxx:abcdefghijklmnopqrs’ changed from ONLINE to OFFLINE (BRIDGE_OFFLINE)
2020-10-21 21:54:34.089 [hingStatusInfoChangedEvent] - ‘innogysmarthome:RST:xxxxxxx:abcdefghijklmnopqrs’ changed from ONLINE to OFFLINE (BRIDGE_OFFLINE)
2020-10-21 21:54:34.094 [hingStatusInfoChangedEvent] - ‘innogysmarthome:RST:xxxxxxx:abcdefghijklmnopqrs’ changed from ONLINE to OFFLINE (BRIDGE_OFFLINE)
2020-10-21 21:54:34.103 [hingStatusInfoChangedEvent] - ‘innogysmarthome:RST:xxxxxxx:abcdefghijklmnopqrs’ changed from ONLINE to OFFLINE (BRIDGE_OFFLINE)
2020-10-21 21:54:34.109 [hingStatusInfoChangedEvent] - ‘innogysmarthome:VariableActuator:xxxxxxx:abcdefghijklmnopqrs’ changed from ONLINE to OFFLINE (BRIDGE_OFFLINE)
2020-10-21 21:54:34.118 [hingStatusInfoChangedEvent] - ‘innogysmarthome:RST:xxxxxxx:abcdefghijklmnopqrs’ changed from ONLINE to OFFLINE (BRIDGE_OFFLINE)
2020-10-21 21:54:34.124 [hingStatusInfoChangedEvent] - ‘innogysmarthome:RST:xxxxxxx:abcdefghijklmnopqrs’ changed from ONLINE to OFFLINE (BRIDGE_OFFLINE)
2020-10-21 21:54:34.130 [hingStatusInfoChangedEvent] - ‘innogysmarthome:RST:xxxxxxx:abcdefghijklmnopqrs’ changed from ONLINE to OFFLINE (BRIDGE_OFFLINE)
2020-10-21 21:54:34.139 [hingStatusInfoChangedEvent] - ‘innogysmarthome:VariableActuator:xxxxxxx:abcdefghijklmnopqrs’ changed from ONLINE to OFFLINE (BRIDGE_OFFLINE)
2020-10-21 21:54:34.147 [hingStatusInfoChangedEvent] - ‘innogysmarthome:RST:xxxxxxx:abcdefghijklmnopqrs’ changed from ONLINE to OFFLINE (BRIDGE_OFFLINE)
2020-10-21 21:54:49.287 [hingStatusInfoChangedEvent] - ‘innogysmarthome:RST:xxxxxxx:abcdefghijklmnopqrs’ changed from OFFLINE (BRIDGE_OFFLINE) to ONLINE

And then some time later

2020-10-21 21:55:48.767 [hingStatusInfoChangedEvent] - ‘innogysmarthome:bridge:xxxxxxx’ changed from OFFLINE (COMMUNICATION_ERROR): java.util.concurrent.TimeoutException: Total timeout 10000 ms elapsed to ONLINE
2020-10-21 21:55:48.779 [hingStatusInfoChangedEvent] - ‘innogysmarthome:RST:xxxxxxx:abcdefghijklmnopqrs’ changed from OFFLINE (BRIDGE_OFFLINE) to ONLINE
2020-10-21 21:55:48.822 [hingStatusInfoChangedEvent] - ‘innogysmarthome:RST:xxxxxxx:abcdefghijklmnopqrs’ changed from OFFLINE (BRIDGE_OFFLINE) to ONLINE
2020-10-21 21:55:48.829 [hingStatusInfoChangedEvent] - ‘innogysmarthome:RST:xxxxxxx:abcdefghijklmnopqrs’ changed from OFFLINE (BRIDGE_OFFLINE) to ONLINE
2020-10-21 21:55:48.838 [hingStatusInfoChangedEvent] - ‘innogysmarthome:RST:xxxxxxx:abcdefghijklmnopqrs’ changed from OFFLINE (BRIDGE_OFFLINE) to ONLINE
2020-10-21 21:55:48.877 [hingStatusInfoChangedEvent] - ‘innogysmarthome:VariableActuator:xxxxxxx:abcdefghijklmnopqrs’ changed from OFFLINE (BRIDGE_OFFLINE) to ONLINE
2020-10-21 21:55:48.884 [hingStatusInfoChangedEvent] - ‘innogysmarthome:VariableActuator:xxxxxxx:abcdefghijklmnopqrs’ changed from OFFLINE (BRIDGE_OFFLINE) to ONLINE
2020-10-21 21:55:48.889 [hingStatusInfoChangedEvent] - ‘innogysmarthome:RST:xxxxxxx:abcdefghijklmnopqrs’ changed from OFFLINE (BRIDGE_OFFLINE) to ONLINE
2020-10-21 21:55:48.891 [hingStatusInfoChangedEvent] - ‘innogysmarthome:RST:xxxxxxx:abcdefghijklmnopqrs’ changed from OFFLINE (BRIDGE_OFFLINE) to ONLINE
2020-10-21 21:55:48.893 [hingStatusInfoChangedEvent] - ‘innogysmarthome:RST:xxxxxxx:abcdefghijklmnopqrs’ changed from OFFLINE (BRIDGE_OFFLINE) to ONLINE
2020-10-21 21:55:48.908 [hingStatusInfoChangedEvent] - ‘innogysmarthome:RST:xxxxxxx:abcdefghijklmnopqrs’ changed from OFFLINE (BRIDGE_OFFLINE) to ONLINE

And then I have to change it again because it was not changed.

1 Like

Hi Sven,
these are exactly the same log-entrys as mine. So it seems to be a more general problem or we both have a wrong configuration.
I’m surprised that there aren’t more people with the problem.

I have a “little” workaround for rules that are triggered by a cron-event: I copied and renamed the rules (with the extend “_livisi_problem” in the rule-name :wink: ) and let them fire exactly one minute later. During this one minute the bridge seems to become online again. It didn’t work properly but almost in 90% of all time rules (it’s not amusing to enter the bath in the morning and it is at about 10°C…).

Hope to find a solution,
Andi

I have exactly the same issue.

Seems to be fixed in 2.5.10.

See https://github.com/openhab/openhab-addons/issues/8734

Hi chrispman,
thanks for the good news.
Can you please tell me where to get the version 2.5.10? I’m able to install a binding via jar file to my openhab-system, but I don’t know how to compile and build the jar file (including downloading the source files).

Kind regards,
Andi

Well I just did an openhab2 apt-get dist-update/upgrade on the Raspberry Pi, everything, including the binding, was updated automatically.

I think this issue #8734 is still open (by @Novanic)

innogysmarthome Bug Fixes 8741 Fix - No commands can get executed after a few minutes (#8734)

Thx @chrispman.

I tried to upgrade to 2.5.10 via openhabian-config but got an error.

I’ afraid I have no knowledge of openhabian.
Seems like youre still on jessie (debian8?).

Perhaps do not use the allow-downgrades option:

--allow-downgrades
       This is a dangerous option that will cause apt to continue without prompting if it is doing downgrades. It should not be used
       except in very special situations. Using it can potentially destroy your system! Configuration Item:
       APT::Get::allow-downgrades. Introduced in APT 1.1.

Maybe try:

apt-get update; apt-get install openhab2
Reading package lists... Done
Building dependency tree
Reading state information... Done
openhab2 is already the newest version (2.5.10-1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Openhabian-config is is a tool (menu) with which you can upgrade automatically.
The command with the downgrade option is baked into the tool, but apparently doesn’t work this time

See: https://www.openhab.org/docs/installation/openhabian.html (openhab-configuration-tool)

In the meantime I have manually performed the upgrade. Thx for the reply. @chrispman

Hi Chrispman,
many thanks!!!
I tried a dist-update and it seems to be the solution. I didn’t know before that the 2.5.10 innogy Binding was already part of the openhab distribution.

Greetings,
Andi