Problems with inplace migration from OH 2.5 to OH 3 using openhabian on Raspberry Pi 3+

I am running Openhab 2.5 on a Raspberry 3+ since about 1.5 years and in general I am very happy with it.
Running about 10 bindings with about over 200 items (Rollershutters with KNX, Pluggit Ventilation Unit with Modbus, some Zwave Sensors etc.)
Since it is recommended to switch to OH 3 I did an inplace migration with openhabian-config by first selecting (option 01) the OH3 branch and the installing OH3 (option 03).
It installed successfully (no errors in log after restarting) and I basically could run my original OH2 environment via the Basic UI after changing a few things:

  • had to manually adapt the smb.conf in order to get the right shares
  • the weather binding was gone (1.0 Binding)
  • had to adapt some time dependent variables in the rules
    Nothing unexpected so far (great job! kudoos to the team).
    Then I wanted to use the new UI and start digging into the semantic model.
    I watched the openHAB 3 Tutorial 2 from BangerTech and tried to do exactly what he did, installing the NTP Binding, use the datetime Channel of the LokaleZeit Thing to create the Datum Und Zeit item.
    And it appeared in the item list:

ItemsListAfterAddingDatumUndZeit.pdf (104.5 KB)

Clicking on the item produced the following:

ItemDatumUndZeit.pdf (81.2 KB)

The actual value was not displayed. I changed the state description and added the pattern below but that did not have any effect either.
In general no values are displayed for any of the items I am selecting and preselection values in fields are not displayed (for example selection of timezones when configuring the Lokale Zeit thing.
I suspect that something with the internal database of OH3 is wrong, does anyone have any idea?
Any help greatly appreciated!

Btw. yesterday I tried it with the the Main branch starting with my old OH 2.5 image and got the same result…

I suggest you read the instructions more carefully. They don’t tell you to switch branches, do they.