Problems with OH2 Orvibo Binding - No reply from S20 sockets

Hi Everyone,

First post here so I hope I manage to explain my self OK. I’ve been using OH1 for a while but when I saw there was an OH2 binding for Orvibo S20 sockets I bought a couple and have installed a test OH2 system on a RPi3.

Having associated the S20 sockets with my WiFi and got them working with the Orvibo app I set to work integrating them with my OH2 setup - this is where it all started to go wrong!

I wasn’t able to auto discover anything from within the PaperUI so added the things manually as follows;

Thing orvibo:s20:5ccf7f2e8324 [ deviceId=“5ccf7f2e8324”]

I had to use the mac address as the end of the channel ID otherwise the Thing would not go online - after a few seconds with a channel definition of say orvibo:s20:ss1 the thing would go to unitialised.

So I did a bit more digging!

Log file first and I found;

2016-11-19 10:17:28.490 [ERROR] [ome.core.thing.internal.ThingManager] - Exception occured while initializing handler of thing ‘orvibo:s20:ss1’: java.lang.IllegalArgumentException: hexBinary needs to be even-length: SS1

So I deleted my thing definition and scanned for new things - this time it found the thing with the mac address that I had deleted, but not the other one that was connected to the network.

So I set this up with the default ID of 9C2960E3 and filled in the mac address as that field was blank. This time the Thing went online but didn’t work.

Having tried 2 different OH2 installs at this point (the RPi one and one on an old i386 laptop with ubuntu 16.04) I noticed that the following error was generated on the install without the thing defined;

2016-11-19 10:17:31.967 [WARN ] [] - No handler found for message 68 64 00 1A 63 6C 9C 29 60 E3 20 20 20 20 20 20 E3 60 29 9C 20 20 20 20 20 20

But from the UDP message format I found ( it appeared to be putting the channel ID (9C2960E3) where I was expecting to see the mac address. When I changed the channel ID to the mac address for a manual Thing configuration things got better when I saw the following error in the instance without the thing setup;

2016-11-19 11:06:26.328 [WARN ] [] - No handler found for message 68 64 00 12 71 67 5C CF 7F 2E 83 24 20 20 20 20 20 20
2016-11-19 11:06:26.397 [WARN ] [] - No handler found for message 68 64 00 1E 63 6C 5C CF 7F 2E 83 24 20 20 20 20 20 20 24 83 2E 7F CF 5C 20 20 20 20 20 20

At least I was now seeing the correct mac and reversed mac address in the messages where expected. From wht I can tell these are correctly formatted discover and subscribe messages so OH2 side looks OK but Orvibo side doesn’t as I don’t see the 0x18 long subscribed message in response to the 0x1E long subscribe message (message code 0x63, 0x6c).

Despite my lack of experience with Wireshark this was my next port of call - apologies if I deomonstrate my ignorance of networking here!!

So when filtering for udp port 10000 traffic I can see packets originating from the IP of my OH2 machine but nothing from the Orvibo sockets - at all.

I also tried using watching udp 10000 on wireshark when using the mobile app (called HomeMate now) and at initial app startup following reboot there is a burst of udp10000 packets with the orvibo code 0x68 0x64 from the android device but nothing in reply. There is no udp 10000 traffic on switching events.

I can’t see non broadcast traffic I assume due to being in a switched network but playing with packet capture on my router I can see a conversation between the android device and and between the orvibo and the same IP when I perform switching events in the android app. Again all the data portions begin with 0x68 0x64.

I obviously didn’t open the switch to look inside but internally it no longer looks like any pictures I’ve found on the internet, the wifi module has changed and is now on the top of the board and the pcb says it is a WiFi_Socket_B25UK_V4.1 and is dated 2016-02-22.

It therefore looks like there could have been a significant revision to the Orvibo S20 and I for one do not have the skills or knowledge to investigate further.

If anyone involved in the binding development can help me get these going or if I can do any further testing please get in touch!!

Thanks for taking the time to read this…


Looks like received pack can NOT find match command handler.