Problems with openhab 2.5.10

since update to 2.5.10 i have some bugs and errors in the log.

i created also another topic:

and also http errors:

Some things are broken since 2.5.9, some settings in the sitemap not working anymore

Try to restart openhab and wait some 10 minutes. If this doesn’t help, try again. Even though i am not shure, if this solves your problems, this procedure often helps.

When oh is updated, it cleans its cache at the end of the update and restarts. This may lead to situations, where rules are run before items are red / initialized. Another restart while not cleaning the cache before helps most of the times. [this is what i understood, maybe wrong partly]

I have a similar thing; lots of error messages after the upgrade to 2.5.10.
I am restarting the second time as we speak…
It looks like the type of error msgs has changed, an indicator it should be OK after that. [and it was].

However, I do not believe the system should behave like this.
Usually, with any system I have experienced so far, when it restarted, it came up clean. Considering the OH startup can easily take up to 15 minutes, and then restart another 15 minutes, means this system is offline for 30 minutes… which I find odd (to say it nicely).

Why did this behaviour seemingly occur when 2.5 was released?
Why is is it not seen as a major bug that needs fixing?

A long time ago, when I was a Systems Engineer for a large operations centre (>80,000 users), the rule was no “red” error in system logs. These had to be resolved, even if it meant to contact the vendor to have it fixed.

Ever since, I run my systems to a state where no errors occur.
This has not been possible with OH.

Before I do a update, I delete the userdata folder (because I have everything file based configured) so the cache is cleaned, all add on will be fresh installed, than I wait for 5-10 minutes and restart, in the most cases it’s working than, if I have errors in the logs after this reboot I try to restart more times, but now it doesn’t help

Why did this behaviour seemingly occur when 2.5 was released?
Why is is it not seen as a major bug that needs fixing?

Very good questions. And I totally agree.
Unfortunatly everyone seems to be aware of this kind of design beeing very bad. But noone seems to work on a solution… Maybe its due to openhAB3 coming… I have yet to see if the start up procedure is the same… I really hope not.

Most of the time i did an 2.5.x update, i had to struggle with the restart. I’m bit impatient at times, so i thought “my fault” and started to analyse. At the end most of the times the restart did it.
Sorry to read, that this is not the case for you.
As there had been at min. two 2.5.10 packages, with the first of it being erroneous, you might try to reinstall 2.5.10 - if you did the update right after kai postet the release.

If this is not a solution, you have to analyse your errors ins the log one after another. errors related to echo devices often go away, if you “logout and create a new device id” for amazon echo control at :8080/amazonechocontrol/ f.e.

If you already know and have tried all this: sorry. Just drill deeper into the log (setting it to debug of course).

Good luck!

FWIW, with symptoms like these (multiple restarts do not help) I actually apt purge (not just remove), reinstall openHAB and reimport my config.
This will get you rid of any potentially noxious leftovers that accumulate in your installation throughout a series of upgrades.

Just ensure you have backups available before you do (config AND disk level).

It’s been around for a long time (prior to 2.5). But the errors reported above do not look like the errors that a restart of OH is recommended to solve. Only when:

  1. a cleaning of the cache has just occurred (e.g. on an upgrade/downgrade)
  2. Items are defined in .items files
  3. the errors reported from Rules and the sitemap are complaining about Items not existing

should a wait and restart of OH be used. All other errors are caused by something else and may require a different solution.

Hours and hours have been spent trying to fix it without a suitable solution having been found. The restart of OH is a work around. It’s notable that if Items are stored in JSONDB instead of .items files the problem does not appear to occur.

The cache gets cleaned during an upgrade anyway. And deleting all of userdata also deletes the MapDB, RRD4J, and SQLite databases if you happen to be using any of those for persistence. It will also delete your openHAB Cloud Connector UUID and secret which will require resetting up your account.

I do not recommend just deleting all of the userdata folder unless you know for sure there isn’t other stuff being stored in there by add-ons and bindings you are using too. I see on my system a folder in userdata for MQTT, Zwave, and Zigbee too.

The maintainers made a best effort to solve the problem. A viable solution has not been found. If someone else wants to take a crack at trying to solve it they are welcome to. I myself spent about 40 hours trying to figure it out (learned a hell of a lot about Karaf in the process). But you are right, no one cares… :angry:


Thats not what I wrote, Rich.

Thank you for a sensible|reasonable explanation…
Given OH3 and the direction to use the UI for all but rules; the issue can be avoided altogether. Good enough for me. :slight_smile:

And just to be clear, the UI, namely PaperUI and for OH 3, Main UI is not the only way to put stuff into JSONDB. You can also use the REST API directly, at least some operations are supported, and in a pinch the JSONDB can be edited by hand.

Also, in Main UI you can access the raw code in mouse l most cases so you don’t have point and click your way through everything. And at least for Items there is an excellent import function where you can import your .items definitions in bulk.

I had a similar issue. After the update from 2.5.4 to 2.5.10 yesterday the rules did not work.
A clean cache and restart resolved the problem.
A bit annoying but the fix works and is easy.
Not sure but I think I had it in the past also already a few times.
It definitely does not look like an easy one to solve, probably some dependency / sequencing in the whole framework. Constant, easy reproduction is also not easy (unless when working with containers I suppose) which makes analysis also though.
Should we effectively not make a non-critical bug entry just to keep track of it? Unless 3.0 fixes this by design?

An issue is already open on GitHub. I’ve not seen reports of this problem on OH 3. On OH 2.5 or OH 3 the problem she’s not occur with Items that are defined in JSONDB.

Note that the problem occurs only when the cache is cleared. And the work around is it wait for oh to come up and restart without another cache clearing.