Problems with Sensors in OH2 with ZWave

i recently installed OH2 and used my Aeonlabs Z Wavestick Gen5 that i used before on OH 1.8.

Moved my Items and sitemap to OH2 and all nodes were found also they are shown as online.
But they dont send updates. Also oh2 is stuck at “Lauchning the openhab runtime…”.
Maybe this is the root problem but i have no idea how to solve this.

Anyidea how this can be solved?

I would say that if the runtime isn’t running, then neither will the bindings…

The first question is “what is the problem”. The answer to this is normally found in the logs - I’d suggest to look in the logs to see what this shows…

i checked the log file and changed the items to the new syntax. But i still have no idea why it isn’t running.openhab.log - Editor.pdf (207.8 KB)

I’m not sure what’s happening - there are a lot of exceptions in your log so I suspect there’s something fundamentally wrong somewhere.

What version of OH are you using? At least the ZWave binding doesn’t look like the snapshot version?

It’s quite difficult to use the log when printed as a PDF - I know the forum doesn’t allow text files, but it’s best to upload a text file renamed to XML.

The Sensors are now working, more or less. Some still have problems, but i think i made mistakes in the Item configuration.

I am currently running openHAB 2.0.0.-1.

Well should have thought of that.

openhab.xml (251.5 KB)

There’s still the same ZWave errors in there about missing handlers. I’ve only seen this in a pre-release version so if you’re running the release version, then I’m not sure why this is happening.

One other point I should have mentioned (sorry) - the logs aren’t very useful unless debugging is enabled - we get errors with the standard log, but it just tells you somethings wrong - to work out what, we need debug level logging…

How do i use debug in OH2? I assume it works diffrent compared to OH 1.8 or 1.9.

Take a look in the docs I referenced above - about half way down there’s info about defining what to log.

Tried that, but my SSH gives the notification “Access denied”.

Well, I guess that needs to be resolved first then ;). I’m not sure why the console access wouldn’t work - might pay to have a look around the forum to see if others have such an issue, otherwise post a separate thread about it?