Problems with Smart Home Designer

Hi guys!
I’m trying to work with Smart Home Designer and OH2 on RPI3. I can view and edit the files and browse the folders.

But my problem is that I can not save the modified files. Also, I can not select openHAB-conf as the configuration folder. I can only select the subfolders.

I have the normal version for windows 64 bit.

Any idea what the problem might be?

That sounds as if the samba shares are not configured correctly.

I am using the default settings for openhabian. Should I change something?

I’m using them also ( only difference is an added share for the sys folder) and it is working!
I wouldn’t change, but checking the settings in the file might show the reason or show that it has to be something different.

How could you compare with your file?

It’s too large to copy in a forum post

I’m talking about the configuration of the samba shares,to be found in the etc/samba/smb.conf

I also talk about the same file :sweat:

My question is how can I check that it is correct?
And if there was some way to compare your file and mine to see where the error might be.

Compare it with the documentation

1 Like

Hi @opus!

After reviewing the documentation you told me I changed this:
Create mask = 0665
Directory mask = 0776

Create mask = 0777
Directory mask = 0777

That allows me to save the files now! :+1:

But I still can not use the smart home well. I can not select openhab-conf as the configuration folder.

From your original post it SOUNDED as if the samba setup could be wrong, because of that I showed you link to the documentation.
You compared setup with the documentation and decided to change something.

Obviously that didn’t help.

In the initial post you stated two problems. The first was that you could only open files, but you couldn’t write to them (i.e. change them). Is that still the case?
The second was that you "can not select openHAB-conf as the configuration folder. I can only select the subfolders."
If that is the case, please show the respective section of your “smb.conf”.

I had two problems:

  • I could not save the changes to the files. (This problem was solved with the changes in “create mask” and “directory mask”)

  • I could not select openhab-conf as the configuration folder. (This problem still exists)

This is my “smb.conf”

comment=openHAB2 site configuration
only guest=no
create mask=0777
directory mask=0777
veto files = /Thumbs.db/.DS_Store/..DS_Store/.apdisk/.*/
delete veto files = yes

Starting with the write permission, to whom do the files belong and as which user are you connecting from the remote machine?
On my system the only folders in etc/openhab2/ are sitemap, items, rules etc. . No subfolder conf exists. I think you have all you need.

I’m sorry but I’ve been working with RPI and raspbian for a short time.

I do not know anything about the permissions of that folder.

And openhab-conf is just the default name in that section. It really is the openhab2 folder. Its path is “path = / etc / openhab2”. You can see it in the previous message.

Have you considered openHABian? It’s a great option for people who aren’t as comfortable configuring Linux. It has automated scripts that handle both samba configuration and fix permissions.

1 Like

Yes, I have openhabian

If you have the current version, try running the “fix permissions” entry under openhabian-config. I don’t have it in front of me but I think it’s under the system tweaks menu.

In your first post you said : [quote=“David_Jurado, post:1, topic:31835”]
Also, I can not select openHAB-conf as the configuration folder. I can only select the subfolders.
So, if you can seethe subfolders, there is nothing else to see.

Ok then this is already fixed.

I thought I should see the environment in this way.

But I only see one folder.

I’m sorry for the inconvenience.

Thank you very much for the help.

In this case: No it’s not fixed. You want to see something similar to the first image.

From your second image it gets clear that you have selected the items folder. That is not correct. You need to select the root folder (which contains the folder items, rules, sitemaps, …).

Check: and

I needed to do this step.

“Right click a share and assign a drive letter”

Now, I can work properly.

I’m sorry for the inconvenience and thank you very much for the help! @ThomDietrich