Problems with the zigbee binding with CC2531 since recent update

Hi all,

back in March/April and with OH3 I had a fully functioning setup with a CC2531 and multiple IKEA TRADFRI bulbs. This setup stopped working some months ago. Initially I suspected my CC2531 to be broken as the green LED stop working. After waiting some time for updates I bought a new CC2531 (Firmware: Koenkk DEFAULT 20201127) as replacement. Unfortunately the system is still not working.

Here is what I tried:

  1. Updated my OH3 system to the latest stable version (OH3.1)
  2. Deleted all old config of the Zigbee binding and reinstalling it
  3. restarted OH3
  4. Added the CC2531 as CC2531EMK Coordinator (this part seem to be working, the Thing is shown as “Online” and the LED stays green)
  5. Tried to add aTRADFRI Bulb as previously (start a scan, 5 x off/an to reset the bulb and select the newly discovered Thing)

I am not sure, if it is even the bulb that is found. Zigbee has discovered as “unknown zigbee device”. I am pretty sure that in the past it was discovered as “TRADFRI bulb GU10 WW 400lm”. Nonetheless I tried installing it. The new Thing is added but stays offline. The system says “Node has not completed discovery”. I found some errors into the same topic:

Unfortunately the problem there is “fixed” by the users going over to zigbee2mqtt. I would like to stay with the zigbee binding. Are there any other steps I could try? I activated logging as described in the docu. As a new user I am not allowed to upload it, but it does not look very interesting.

Best Erik

I wanted to give an update on the situation. After trying numerous thinks I found on the internet I gave up using the CC2531. Instead I bought a SMaBiT Zigbee Controller (AV2010/10) because I found it mentioned in the forum multiple times. The new sticks works flawlessly and after pairing all devices work as expected.

Best Erik

p.s. If anybody knows how to debug what happened to the CC2531 write me. I am willing to do testing and help where I can.