Problems with Z-Wave-Stick


System-Info below…

My Problem:
I use a RasPI 3B+.
I use Z-Wave with a USB-Stick and EnOcean with EnOceanPi (the small Add-On-Board).
I moved the BT device (I want to use it for presence-detection) to /dev/ttyS0 by an overlay.
When ever I make changes to the configuration of the Z-Wave Stick. The communication to it gets lost because the system says, that the serial port is not availabe.

On the inital Installation of the Z-Wave-Stick I entered the port (/dev/ttyACM0) --> It was a textfield.
Now this field is empty and its no textfield any more. Now I have to choose the port and there is only the port of the EnOcean-Board available.

When I restart the OH2-Service, the Z-Wave-Stick is online again after about 20 secs. The EnOcean-Board takes 2 - 3 Minutes. The long time is strange but no problem for me.

Some Z-Wave-Things need other TeachIn-Settings than others so I had to boot a few times to get all the Things in. But it looks like ther is someting wrong wit hthe hardware-binding…

I tried OpenHABian but there I was not able to get the Z-Wave-Stick online again. Does not matter what I tried :frowning:

Thanks for any Help

  • Platform information:
    • Hardware: _RaspBerry 3B+
    • OS: Linux raspberrypi 4.14.79-v7+ #1159 SMP Sun Nov 4 17:50:20 GMT 2018 armv7l GNU/Linux
    • Java Runtime Environment: openjdk version “1.8.0_152”
    • openHAB version: 2.4.0

Bus 001 Device 006: ID 0658:0200 Sigma Designs, Inc.
Bus 001 Device 007: ID 0424:7800 Standard Microsystems Corp.
Bus 001 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub