Pull request (build the project fail)

Hi everyone,

I’m trying to make a pull request to the openhab-core project to solve this issue.

But the review required failed because it can’t build my project as shown in the image below:

And the error message shows that:

He can’t build my project.

The project is built by running the following command:


I don’t understand how to solve this problem because when I run this command locally for my project, it works fine and my project is well built.

My pull request is here. What can I do to ensure that my project is well built?

Someone can help me?

Thank you,

Nicolas Gennart.

Seems you are working on an older version, as your PR shows old dependency


1 Like

I thought I was up to date, but ok thanks I’ll look into it.

I have put the pom.xml file like that:


And I have still the error…

PR build is still running……

All checks passed, so it seems you solved it.

1 Like

Yes thank you, I finally found the error, it was in my unit test.

1 Like

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.