Pushover stopped working


(Kai Ricken) #21

Hi Sasha,

the following steps solved my problem:

  1. open https://pushover.net in your browser
  2. copy or export the site certificate in PEM Format on your openhab server
  3. on your openhab server enter the directory which contains the java keystore, for example /etc/openhab/jetty/etc
  4. Import the PEM-Cert: keytool -import -alias pushover.net -keystore keystore -file pushover.net.pem
  5. restart openhab

That’s it.


(Sasha) #22

Done all the steps…
Still the same


(Sasha) #23

That’s really getting too complicated. I am ready to give up and use other notification engine…


(John Cocula) #24

@sasha_jpr, did you also add the

-Djavax.net.ssl.trustStore=/etc/openhab/jetty/etc/keystore

argument to your openHAB startup? I think the advice from @Denkermatic ought to solve the issue. Also, are you using Oracle JDK and not OpenJDK? You might find different results if that’s the case (in which case the common CA certificate might already be present and so no extra steps would be needed).

I am marking the related issue as “documentation” because I am confident that that is the root cause.


(Sasha) #25

@watou yes, I’ve added the parameter. Please confirm, should it be /etc/init.d/openhab?

I use OpenJDK. Should I change it to Oracle one?

Cheers!


(Sasha) #26

AAHHH, finally.
SOLVED by changing Open JDK to Oracle.

Thanks everyone for help!

Here is the link how to do that


(martiniman) #27

Hi, after update Ubuntu to v18, i got the same error.
I add extra java parameter, but this doesn’t help, Oracle Java is used.
What else can i do to get pushover works again?