Pushover withAttachment fails with "Method failed: HTTP/1.1 400 Bad Request."

UPDATE: Solved by changing the extention of the picture!!!
snap.jpeg does not work
snap.jpg WORKS. crazy…

Hi there,

The following notification in the rule works fine and the message pushes through.

But when I add the withAttachment bit it refuses to work and gives me 400 BadRequest in the logs

[WARN ] [ab.action.pushover.internal.Pushover] - Method failed: HTTP/1.1 400 Bad Request.

I have tried using the pushover API directly with curl and it works from the commandline, but if
I call it from within the executeCommanLine the message never gets pushed.

curl -s --form-string “token=mytoken” --form-string “user=mytext” --form-string “message=here is an image attachment” -F “attachment=@/tmp/snap.jpeg” https

Any ideas where to dig?


I see you opened an issue on github. :+1:

Link to the issue for others:

That was logged in the wrong tracker, I think.
The pushover action is a 1x action.

Additionally, no debug log was provided and that’s very much needed.


I have provided the requested missing debug log and the enironment details, and noticed that I can not replicate the bug anymore.