Putty on Openhab 3.2 Raspberry Pi OS (lite) Backup Restore

Hi all,
I’ve been running 2.5 for some time with no issue. I’ve started a new install on a PI4. Everything went well. The next step is to recreate my 2.5 install, however, I cannot login with Putty. I’ve tried the default password and port 8101 to no avail. Any tip would be most welcome.

Secondly, is it possible to restore a 2.5 backup to a new 3.2 installation?

Thank you. Happy holidays.



  • Platform information:

    • Raspberry PI 4 - 4G 32G
    • OS: what OS is used and which version: Raspberry Pi OS (lite)
    • Java Runtime Environment: 11
  • Issue of the topic: Cannot log in remotely with Putty

  • Please post configurations (if applicable): Base, nothing configured yet

    • Items configuration related to the issue: None
    • Sitemap configuration related to the issue: None
    • Rules code related to the issue: None
    • Services configuration related to the issue: Nothing changed yet

How did you install the new box ? Which image did you use ?

@mstormi, thank you for your reply. The latest image from the website.
openhabian-pi-raspios32-202112021757-gitbb960d8-crc8b6dfb1b.img Is there a better one?

I used Etcher to make the SD.



Are we talking about ssh‘ing into the OS (ssh pi@raspberrypi) or are we talking about openHABs Karaf console?
I would guess Karaf since you are mentioning port 8101? Did you expose the Karaf console for external access? The default is that the console is only accessibly locally (first ssh‘ing onto the machine, than connecting to the console…)
You can expose the Karaf console to external access via openhab-config.

Second point - is SSH automatically enabled with openHABian? At least with Raspbian OS (on which openHABian is based) you have to add a text file named ssh to the boot partition after writing the SD Card with Etcher :thinking:

Update 2: All good now. I’ve updated to v0.76 of Putty and now it’s working as advertised.

Thank you.

Update: I’m able to connect with my MAC in the terminal window, using: ssh openhabian@ Still no love with Putty on my PC… Investigating.



Thank you for your reply @fex. I am no expert, however, on HAB 2.5 I am able to SSH in on port 22 with no issue. HAB 2.5 shipped with generic Debian, 3.2 ships with Raspberry Pi lite OS, perhaps there is a difference there I am not seeing. See below for other responses.