PVR channels from Kodi are not shown in Sitemap

Hi all,

I did setup OpenHAB2 and I want it to connect to my Kodi instances.
Basic communication is working fine, i am able to play/pause volum up/down and so on.

I did follow the sample code from here https://www.openhab.org/addons/bindings/kodi/#full-example to be able to selcet a TV channel or a Radio channel from Kodi.

  • But for whatever reason I do not see any TV channel in Kodi. The selection on my sidemap is empty if I click on it.
  • The funny thing is if i click on Radio channels I do see some TV channels (looks like all the HD channels i receive) but no radio channel at all.

Would be great if you have any hints or proposals how I can procceed.
Thanks in advance.


now I posted a bit to fast…
Last thing i tried now is to restart OpenHAB2 after all those changes to the config, and guess what…
now I see all the channels correct.

Looks like OpenHAB has some issues reading new configs files properly on the fly.
Does anyone know why? Or how I can avoid it?

My setup is a RPI3 hosting OpenHAB and samba and I do all my configuration from a Windows machine with Visual Studio Code Plugin for OpenHAB.

Thanks for any hint to avoid this in the future.

@cweitkamp would know for sure, but maybe the Kodi binding uses state options to populate the list of TV and/or radio channels. If so, by any chance are you also running the Sony binding? There’s an issue that was fixed recently in the Sony binding that was impacting other bindings use of state options.

Thanks for the response. So I will wait if @cweitkamp will reply.

No Sony binding on my system so far, so it must be a different issue.

Oh well, it was worth a shot…

Yes, the binding uses dynamic state options for this channel. And there is a polling Job for retrieving them. I am afraid I do not know why it was not working on the first run. But I am glad that it is working now. :wink: Maybe the state provider service was not initialized properly or the polling job did not run in the few minutes you looked for it.

Thanks for replying. Sound like I need to keep it in mind for the future :slight_smile: