Pzem 004t things

I have a PZEM device installed, I don’t know how can I add this device to .things?
I did and it doesn’t work for me :frowning:

Thing mqtt:topic:Solar “Pomiar Solar” (mqtt:broker:MosquittoMqttBroker) {

Type number : Solar “Napięcie” [

Type number : Energia_Solar “Moc” [


tasmota pzem mqtt config:


Bridge mqtt:broker:garage "Mosquitto" @ "Garage" [ host="", port=1883, secure=false, username="MQTT-login", password="MQTT-passw", clientID="g-oh",enableDiscovery=false ]


Thing mqtt:topic:garage:pzem "PZEM-004t" (mqtt:broker:garage) @ "Garage" {
        Type number     : rssi      "WiFi Signal Strength"  [stateTopic="pzem/STATE",  transformationPattern="JSONPATH:$.Wifi.RSSI"]
        Type string     : lwt       "lwt"                   [stateTopic="pzem/LWT"]
        Type number     : voltage   "Line Voltage"          [stateTopic="pzem/SENSOR", transformationPattern="JSONPATH:$.ENERGY.Voltage"]
        Type number     : powerload "Power Load"            [stateTopic="pzem/SENSOR", transformationPattern="JSONPATH:$.ENERGY.Power"]
        Type number     : app_power "Apparent Power"        [stateTopic="pzem/SENSOR", transformationPattern="JSONPATH:$.ENERGY.ApparentPower"]
        Type number     : current   "Line Current"          [stateTopic="pzem/SENSOR", transformationPattern="JSONPATH:$.ENERGY.Current"]
        Type number     : today     "Energy Used Today"     [stateTopic="pzem/SENSOR", transformationPattern="JSONPATH:$.ENERGY.Today"]
        Type number     : yesterday "Energy Used Yesterday" [stateTopic="pzem/SENSOR", transformationPattern="JSONPATH:$.ENERGY.Yesterday"]
        Type number     : total     "Total Energy Used"     [stateTopic="pzem/SENSOR", transformationPattern="JSONPATH:$.ENERGY.Total"]
        Type string     : uptime    "Uptime"                [stateTopic="pzem/STATE",  transformationPattern="JSONPATH:$.Uptime"]
        Type datetime   : update    "Update"                [stateTopic="pzem/STATE",  transformationPattern="JSONPATH:$.Time"]
        Type number     : react_pwr "Reactive Power"        [stateTopic="pzem/SENSOR", transformationPattern="JSONPATH:$.ENERGY.ReactivePower"]
        Type string     : fw        "firmware"              [stateTopic="pzem/INFO1",  transformationPattern="JSONPATH:$.Info1.Version"]

Thank you very much for your help, but I had to change the .things code

Type number : powerload “Power Load” [stateTopic=“pzem/SENSOR”, transformationPattern=“JSONPATH:$.ENERGY.Power”]

Type number : powerload “Power Load” [stateTopic=“tele/pzem/SENSOR”, transformationPattern=“JSONPATH:$.ENERGY.Power”]

FYI That’s because @Olymp has changed the Full topic field in their Tasmota settings, whilst yours have been left at default.

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.