Qubino 3phase Smartmeter stops sending data

As suggested by @Bruce_Osborne here …

I open a new topic.
I have the ZMNHXD installed now for about 6 months. Every now and then, it “hangs” I.e. stops sending meter data. Up to about 10 days ago, a recycling of the device had always cured it. At that point, it did not help anymore. I decided to completely remove the device from the system and start discovery again. After a few days of flawless operation, it has started to fail again three times during the last 7 days. Up to now, recycling did solve the problem. How can we get to the root cause of the issue? I have a number of zwave devices, none of them has a similar issue.
I am on Openhab 2.5.11 and the zwave snapshot binding 2.5.12 on a Raspi 4.

Anyone using this device? Does your qubino energymeter run without this type of issue?

Problem continues, additonal hangs within the last few days. It is clearly a ZWAVE Problem, as the display on the device continues to show the correct metering values.
Anybody with similar Problems?

Do you have any information on the problem - at the moment I really can’t help as there is nothing to really go on. If the device stops sending data, then the binding will stop receiving data - is that is what’s happening?

What can I do to find out if this is a SENDER or a RECEIVER Problem?

It happened again yesterday, after 3 days of smooth operation of the device. Channels do not show meter updates (device hangs) but the display of the Qubino continues to show correct meter data.
I did some further testing:

  • edit the Thing - channels do still not show updates
  • restart ZWave Binding - channels still do not show updates
  • restart Openhab - channels still do not show updates
  • reboot Raspi - channels still do not show updates
  • powercycle the Qubino - channels start showing updates again

Is there any other test I can do to get to the root cause of the problem?
What do you suggest?

I’d suggest to get the logs, however if the device just stops sending data, then there’s not really a lot that the binding can do to resolve this. The device should be sending data autonomously - ie the binding doesn’t poll it. If this stops, then it’s either a device problem, or maybe a problem with another device en-route.

Try reaching out to Qubino’s support, they are really good. I had similar problems (with the same product) an it ended with them sending me another firmware for the meter which works much better. If I understand things correctly the firmware I’m on now completely disabled the IR port which I don’t need anyway and that was somehow connected to the sending problems. My meter has now worked flawlessly for over a year.

1 Like

I contacted Qubino support earlier today. They will send me a firmware update. I will report back after I installation of the new firmware.

1 Like

@DanielMalmgren: What firmware version do you have?
I got 4.11.
Another question: do you use S0 security? I actually do.
After some initial operation, openhab again does not receive channel updates anylonger. A Powercycle of the device cure it for a while, until it starts again.
But I find these entries in the DEBUG log:

2021-01-29 21:31:47.273 [DEBUG] [nal.protocol.ZWaveTransactionManager] - NODE 169: Application Command Request (ALIVE:DONE)

2021-01-29 21:31:47.274 [DEBUG] [ng.zwave.internal.protocol.ZWaveNode] - NODE 169: resetResendCount initComplete=true isDead=false

2021-01-29 21:31:47.276 [DEBUG] [ng.zwave.internal.protocol.ZWaveNode] - NODE 169: Incoming command class COMMAND_CLASS_MANUFACTURER_PROPRIETARY, endpoint 0

2021-01-29 21:31:47.279 [DEBUG] [ng.zwave.internal.protocol.ZWaveNode] - NODE 169: Command class COMMAND_CLASS_MANUFACTURER_PROPRIETARY not found, trying to add it.

2021-01-29 21:31:47.281 [DEBUG] [tocol.commandclass.ZWaveCommandClass] - NODE 169: Unknown command class 0x91

2021-01-29 21:31:47.284 [DEBUG] [ng.zwave.internal.protocol.ZWaveNode] - NODE 169: Unsupported Z-Wave command class COMMAND_CLASS_MANUFACTURER_PROPRIETARY

2021-01-29 21:31:47.286 [DEBUG] [nal.protocol.ZWaveTransactionManager] - NODE 169: Commands processed 1.

2021-01-29 21:31:47.288 [DEBUG] [nal.protocol.ZWaveTransactionManager] - NODE 169: Checking command org.openhab.binding.zwave.internal.protocol.ZWaveCommandClassPayload@33e196.

Those entries repeat very frequently, but within different time intervals. Sometimes, it repeats after a few seconds, sometimes it takes a minute or two. I wonder if message apears whenever the meter update channels fire.
The strange thing is though, that after a Powercycle of the device it works for some period of time.

I actually don’t know. How do you know?

I use no security. I have no neighbours within radio range so it doesn’t feel necessary :sunglasses:

In Habmin, (mine is in German though)

or in Paper UI in the PROPERTIES of the Thing.

I’m on 3.0, so I have neither paperui nor habmin. I’ve searched in mainUI but no firmware version to be found there :frowning:

Qubino sent me firmware 4.1 and asked to not use S0 security during inclusion.
Up to now, the device works without issues. Knock on woods.

1 Like

I’ve got a question about my smartmeter (which is kinda off topic, but since we have a thread about the model…):

The reading I’m most interested in is the consumption from my entire house. The really strange thing is that my meter sometimes sends this value to the channel meter_kwh and sometimes to meter_kwh1. Sometimes it’s weeks of using one of the channels, and then suddenly it starts using the second for a while. Is this the same for you? Lately I have simply linked the corresponding Item to both the channels which actually seems to work well, but I don’t really know if it’s a good idea having an Item linked to multiple channels.

If I understand things correctly the channels ending on 2, 3 and 4 corresponds to the individual phases, but I’ve never really understood why there are both channels ending on 1 and channels with no number at all. And obviously my meter is using them in a very strange way…

The values across all three phases are measured with the “-1” channels. So, actual power consumption is “Watts-1”, total energy usage is “kWh-1”. I do not really understand what the channels without a number are used for.

1 Like

Ok, so sometimes my meter does it right, and then sometimes it does it wrong. Kinda weird :slight_smile: