Qubino Flush 2 Relais misbehaves once every x times

  • Platform information:
    • Hardware: Acer Aspire 5315 2Gb RAM
    • OS: _Debian GNU/Linux 9 (stretch)
    • Java Runtime Environment: OpenJDK Runtime Environment (Zulu (build 1.8.0_172-b01)
    • openHAB version: openHAB 2.3.0-1 (Release Build)
    • zwave version:

I have a Qubino ZMNHBD Flush 2 Relais firmware version 5.0 from Qubino that is connected to a be-stable switch, my bathroom light and my bathroom ventilation. My goal is to switch on light and ven when the hardware switch is used, and only switch off the light when it is switched off again. Then a timer will run for 5 minutes and when it ends, the ven will switch off too. In time I would like to make the use of the timer depend the time of day.

Most times this works great, but every once in a while the Qubino behaves differently. After pushing the switch, light will go on, but not the ven. Then after several seconds, the light will go off, and again after several seconds, both the light and the ven will go on. Sometimes, but not every time, I can hear the Qubino switch several times without anything happening before switching the light and ven on. This is very disturbing for my small kids when they go to the bathroom at night.

I moved from Raspi to the laptop and changed to the snapshot version of the zwave binding, hoping this would solve my problem. But it is still the same as with the stable binding.
I never have this strange switching behaviour when I switch on the light through the app, only when we push the be-stable-switch.
Default reporting group: Openhab Controller.
Only sw1 and sw2 have items connected.

My log only shows the intended switching:

2018-07-21 13:49:43.371 [vent.ItemStateChangedEvent] - Lamp_BK changed from ON to OFF

2018-07-21 13:49:43.372 [ome.event.ItemCommandEvent] - Item 'Ven_BK_timer' received command ON

2018-07-21 13:50:56.064 [vent.ItemStateChangedEvent] - Lamp_BK changed from OFF to ON

2018-07-21 13:50:56.067 [ome.event.ItemCommandEvent] - Item 'Ven_BK' received command ON

2018-07-21 13:51:05.078 [ome.event.ItemCommandEvent] - Item 'Ven_BK_timer' received command ON

2018-07-21 13:51:05.080 [vent.ItemStateChangedEvent] - Lamp_BK changed from ON to OFF

2018-07-21 13:56:05.716 [ome.event.ItemCommandEvent] - Item 'Ven_BK_timer' received command OFF

2018-07-21 13:56:05.720 [vent.ItemStateChangedEvent] - Ven_BK_timer changed from ON to OFF

2018-07-21 13:56:05.723 [ome.event.ItemCommandEvent] - Item 'Ven_BK' received command OFF

2018-07-21 13:56:05.727 [vent.ItemStateChangedEvent] - Ven_BK changed from ON to OFF


Switch Lamp_BK "Licht badkamer" <switch>  { channel="zwave:device:e246413d:node24:switch_binary1"}
Switch Ven_BK "Ventilator badkamer" <switch> { channel="zwave:device:e246413d:node24:switch_binary2"}
Switch Ven_BK_timer { expire="5m,command=OFF" }


rule "Ven_badkamer"
	Item Lamp_BK changed

rule "Ven_bad_uit"
	Item Ven_BK_timer changed //from ON to OFF	
	if (Lamp_BK.state==OFF && Ven_BK_timer.state==OFF){

The problem is when the first rule works but I have post the second too in case it could be relevant.
There are some errors in my log that are about other nodes which I don’t understand but I don’t think is relevant.
I also tryed the rule on another Flush2relais that I have, with the same result!
How could I try to solve this?

I see nothing wrong with the code or the log.
This may have something to do with the zwave configuration of your switches.
This is pure speculation as I don’t know zwave only that devices can be set-up to have some autonomous behaviour.

Thank you for your thought. I did exclude the device and include again, I guess any configuration I may have done before should be gone. In HABMIN I see all parameters according what I think should be defaults.
Just now I did ‘re-initiallise’ from HABMIN. This did not solve the problem either.
But after several switches for testing purposes, it now doesn’t switch at all anymore, while still lookig responsive from openhab-side. I guess the relais are faulty???
What a chance this happens now I am trying to resolve this after I have had this issue for 8 months. Really strange.

UPDATE: I took out the device, and wired it outside the wall-mount for testing. Now its switching again and 100% as it should. So now it must be a faulty be-stable switch or wire??? But both the light and the ventilation are now working fine without the Qubino in between. i am puzzled. Any idears are welcome. I will start now with changing the switch and the small wires running from the switch to the Qubino.

UPDATE 2: The Qubino is often not working when put in the wall, but works perfectly when it’s hanging out from the wall. I think the built quality is too poor and stresses coming from stiff wires cause malfunction.
I always put most of the wires into the wall, then the Qubino, and than the be-stable switch. I found out by lots of trial and error that it’s better to first put in the qubino, with the flat back against the back of the hole in the wall, Then put the wires in between the Qubino and the be-stable switch. Now it is working again, and hopefully never stops.
Do others have the same problems? And how is that with Fibaro’s?

No problems, even with a lot of wires hanging around. I have one small electrical wall box with six Fibaro rollershutters and a lot of wires around, works without any issues.