Raspbee2

Tags: #<Tag:0x00007f616f700b20>

I bought a Phoscon Raspbee2 from Dresden Elektronik https://phoscon.de/en/raspbee2/
I am not quite sure how to install
I have installed the deConz bridge in OpenHAB
Phoscon offer 2 methods for installation - the first flashing a SD card - I’m sure this method would work, but I assume it would overwite OpenHAB
I couldn’t get the manual method to work
Has anyone succesfully installed one of these? If simple instructions without assuming too much expereince for a newbie would be appreciated

Yes follow the manual instructions on their page it will install the deconz service to your pi. In short you need to:

Add the deconz repository
Run apt install

What error are you having with manual install?

I fought hell initially also in my headless pi. You are not alone. Once you get it installed let me know. Installation is the first step. There is more config after the install.

Thanks Danny. I tried the RTC Install first - that didn’t work I got a msg about missing files - did I even need it? I think I now have deconz installed correctly.
I plugged in a dimmable light - In paperUI I actually found it manually - I have a “Thing ID”, but in configuration it is asking for the IP address or hostname of the deconz interface. Where do I find that?
If I get that far it will then ask for an API key which will then need to be authorised via the deconz web interface.
I have tried the Phoscon web app. That can not find the gateway.
I feel I am still some way off nailing this!

Your help is appreciated

Have you followed the steps as explained here: https://dresden-elektronik.github.io/deconz-rest-doc/getting_started/ ?
There is an URL that can be used to find your deconz IP address as well as how to request the API key.

Thanks - I tried using postman as described, but not returning IP address or port.

You were able to start the deconz app without any error message and it was running while you tried to find the IP and port ?

Ok if you have the deconz apt package installed then you have first step done.

Step two(the way I did it) of the overall process is run the deconz app and set gateway. This will allow you to verify it is working. If you are on a headless pi setup. You can use another Linux installation possibly a mac to do this. I use Ubuntu with a desktop installed. Then you ssh into the pi and launch the deconz app. The command I use is ssh -X user@pi-ip once in type deCONZ. This was the way I had to do it. Others may have ideas but as I know Linux I chose this method.

Also, I am fairly certain the deconz service file many time should automatically find the gateway. So question is did you setup the serial port? There is a menu item in openhabian config for this.

Lastly, the IP address of phoscon is the ip address of the pi you installed it on. Get your gateway found first then focus in the api key.

**uodate found this online but never tried:
“”You can change it with parameters in the service file /etc/systemd/system/deconz.service --dev=/dev/usbXY“”

I am starting to think I am in over my head with Raspbee2! I have now set up the serial port (thanks!) Still doesn’t make any difference. The Phoscon web app can not find a gateway. I thought Raspbee2 would be a nice way to use Zigbee. I’m starting to wonder if I shouldn’t find a sompler solution. I could use a nice youtube video!

Looks like the deconz service is not running.
What is the output of:

ps -ef |grep -i deconz
sudo netstat -tulpe |grep -i deconz

[23:17:50] openhabian@openhab:~$ ps -ef |grep -i deconz
openhab+ 8548 8097 0 23:18 pts/0 00:00:00 grep --color=auto -i deconz

[23:19:35] openhabian@openhab:~$ sudo netstat -tulpe |grep -i deconz
[23:19:45] openhabian@openhab:~$

This indeed means that the deconz service is not running.
According to one of your previous posts this means that the hardware is plugged in; the serial interface might be / is configured correct but as long as the software/service is not running the port that offers the service is not open and thus the gateway cannot be found.

What kind of Pi do you own ? Is it a Raspberry Pi 4B ?
Did you follow all the hints / instructions that where shown during the installation of the deconz software ( sudo apt install deconz ) ?

Could you provide the output of

systemctl list-unit-files  |grep -i deconz
systemctl status 'deconz*'

This should show a list of services and if they are enabled or not.

please.

I am using Raspberry Pi 4B

[10:45:23] openhabian@openhab:~$ systemctl list-unit-files |grep -i deconz
[12:28:30] openhabian@openhab:~$ systemctl status ‘deconz*’
[12:28:52] openhabian@openhab:~$

I guess this suggests the software is definitely not running

I followed steps 1- 6 for the installation of deconz

[09:25:37] openhabian@openhab:~$ sudo apt install deconz
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
deconz:armhf : Depends: libqt5network5:armhf but it is not going to be installe d
Depends: libqt5widgets5:armhf but it is not going to be installe d
Depends: libqt5gui5:armhf but it is not going to be installed
Depends: libqt5websockets5:armhf but it is not going to be insta lled
Depends: lsof:armhf but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

For some reason some packages were not installed

btw - I appreciate your help!

Do you have any packages set to hold? What version of raspian are you running? I am going to look up commands to check these things. but right not you have some type of apt package issue it appears.

apt-mark showhold Should show the held packages

cat /etc/os-release Make sure it is buster.

Ok here is all the commands you need to install deconz. Please check the two commands in my post above first. But What I have here is the process.


wget -O - http://phoscon.de/apt/deconz.pub.key | \
           sudo apt-key add -
           
           
sudo sh -c "echo 'deb http://phoscon.de/apt/deconz \
            $(lsb_release -cs) main' > \
            /etc/apt/sources.list.d/deconz.list"


sudo apt update


sudo apt install deconz

sudo systemctl enable deconz


sudo systemctl start deconz

A few suggestions, after doing apt update I would do an apt upgrade make sure all is clean after this. If the package install has no errors try to install deconz. It appears you may be stuck on this step the deconz package install currently.

If the deconz package installs successfully then continue on. Check in phoscon if the gateway is found. If not, I am wondering if the command:
sudo systemctl start deconz-init.service will find it. I am not sure what this is for comment says zigbee initialization. If after all of this the gateway is not found you will have to do one of two things.

  1. Run the deCONZ gui. Only way I know how is to have a gui based linux distro and ssh in. If you have access to a mac I think it will work also, but not sure.

  2. Try to specify the zigbee device on the command line as part of the file
    /lib/systemd/system/deconz.service. I have not tried this but saw online others may have.

I am using this image

Stable version does not work with RPi4 8GB
I am told a new version is being worked on that works better with the new Raspberry

[15:22:57] openhabian@openhab:~$ sudo apt install deconz
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
deconz:armhf : Depends: libqt5network5:armhf but it is not going to be installed
Depends: libqt5widgets5:armhf but it is not going to be installed
Depends: libqt5gui5:armhf but it is not going to be installed
Depends: libqt5websockets5:armhf but it is not going to be installed
Depends: lsof:armhf but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
[15:23:42] openhabian@openhab:~$ sudo systemctl enable deconz
Failed to enable unit: Unit file deconz.service does not exist.

Still not working - maybe it is because I’m forced to use a beta version of openhabian

I appreciate your help!

I do not know what this means but according to https://phoscon.de/en/raspbee/install there is an update for WiringPi required if you run Raspbee2 on a Pi 4B.
But this has nothing to do with the errors described in your latest posts.

Need to check that message.

THis needs to be fixed before going further. You may need to ref lash your image if apt is all messed. Could be the fastest method.

what is the output of:

apt-mark showhold
1 Like

Blank!