Raspberry 3 B+ WIFI on Openhabian

Hi Thom, I heard you say that before. How come you favor Ethernet over WiFi?
I simply have the nagging feeling that the wifi connection might be less stable but then again my Hue bridge is oftentimes not reachable whereas the wifi bound Roomba always respond whenever I query it.
For convenience reasons wifi is more practical for me due to where my router is located

Who does not? The only drawback of ethernet cable against wifi is that you need a a cable. Ethernet is far superior in any aspect other than needing a cable.

If your ethernet is more unstable than wifi you have some defect components.

Hi @jayloo, I was in the same troubles as you. Maybe you are helped with the solution that I found today at the Issue list for Openhabian

My summary of the problem would be: The WiFi of the RBP3B+ can become ‘soft blocked’, somehow. This is preventing normal operation of your wireless connection.
The solution is to unblock the wifi adapter with the following command:

sudo rfkill unblock wifi

You can check the status of your wifi adapter with:

rfkill list

Let me know if this was helping you too.

Hi,
I also fought with Pi 3 B + and wifi configuration. The only way I found it is to set the wifi right after fresh installing the openhabian (before any configuration), then you can use raspi-config. In this way wifi works great :slight_smile:

Hm that points is towards something in the config process disabling wifi. Not a nice Outlook for existing users…
I did a fresh install with the SSID and password in the config file on the sd card… To no avail. Do I understand you correctly that you repeated those settings as soon as you had ssh-access to the fresh install?

Hi,

in my case, when I tried to setup wifi after doing some openhabian configuration, there was impossible to run raspi-config (I get message that I should use openhabian-config, not raspi-config), only after fresh install I was anable to used raspi-config, and in this case wifi’ config in raspi-config was anable, and works after openchabian update upgrade …

Hi @Gm2066 - what do you mean by “fresh install”? What were your steps?

Im following these install instructions, but its failing on WIFI also: openHABian | openHAB

many thanks,
Tony.

WiFi with the rpi3b+ has a know problem. Solution is stated here

Thanks @Josar

ran that sudo command in terminal on my mac, and its asks for a password. Is that my router password it needs?

also… seems this command:

sudo rfkill unblock wifi

needs to be run in the @pi terminal using putty, or ssh. If that’s so, then it won’t work as I don’t have a PI ip address that comes up.

Just connect a screen and a keyboard boot up wait till error occurs, unblock the wifi, restart …

Or wait till the fixed is merged and the next openhabian release is out.

only after fresh install I was anable to used raspi-config, and in this case wifi’ config in raspi-config was anable
“fresh install” - just after openhabian instalation before using openhabian config

Just bought a rpi3 b+ and I want to install openHABian, what do you mean by after fresh install? You need to install openHABian and than what? What do I need to do right after that? Do I have access to use rpi terminal?
What do I need to download from git? The source code (zip) or the source code (tar.gz)
In the doc file there are a lot of folders and files for rpi and pine64, which one is the openHABian image for rpi?

UPDATE: just saw the link image on the site, downloaded and write it on the pi using balena. Connected a rj45 cable to my router, plugged in power socket an leave it over night! Next day whe I try to access http://openhabianpi:8080 … nothing happens! Tried also to connect Wifi setting my network and psk in the conf file as is indicated on the site and still nothing. I’m wondering my pi is broken! Or I did something wrong? Could you please tell me your pi card slot when inserting the card inside you have to feel like a click or it just push it there and it stays without any click and when you want to take out just pull the card and it goes out whiteout pressing on it?
Please help!

Any help please? See above updated comm.
Thanks all

that must be quite disappointing.
Could it be that perhaps your router does not recognize the openhabian name in its DHCP?
try it first with the actual IP number that your Pi has in your network.

With regard to your question about the card, I dont own a 3B+, only a 3B and there I just push it in as far as I can… anyway, are you sure your Pi starts up? coz that would settle the card issue. Can you SSH into it?

Still cant boot openhabian on this rpi 3 b+ :frowning:
If i connect rpi to my tv i see the software loading and it says that “setting up wifi connection … Ok” and than “ensuring networking connectivity … Ok started openbsd secure Shell server FAILED”
I was not albe to connect to the configured wifi and it say to check the ssid and pass or that the Signal quality !!!
WLAN 0 interface doesnt suport scanning: network is down
Initial setup exiting with an error
Script’/boot/first-boot.sh’ failed
And After a few more message it say:
Raspbian gnu/Linux 9 openhabianpi tty1
Openhabianpi login:

What to do? PLS help!

ok so when i understand correctly, if you have the openhabian SD card, you cant boot at all?
Seems to me the problem then isnt so much your WiFi but your openhab/raspi install.

What I would advise you for now:
get a new SD card.
write the openhabian image on it.
When finished, keep it in the computer that you used to write the sd card.
Open the SD card in explorer.
on the bootsector, put an empty file, called ‘ssh’
on hat same bootsector, put a file that is called
wpa_supplicant.conf

in that file put the following content:

network={
ssid=“MySSID”
psk=“MyWiFiPassword”
key_mgmt=WPA-PSK
}

and save that.

Put the sd card in your raspberry and start it up…takes some time. easily 30-45 min.
see if it then conects through WiFi
If not, see if it connects through cable

@ewgor Follow these steps, and you will be up and running in no time.

https://community.openhab.org/t/raspberry-pi-3-b-and-debian-vm-setup-guides/65875

Thanks for the suggestion but I already have openHABian installed on my rpi3b+.
I finally managed to get openHAB up and running through lan connection. I have a dumb router from the local tv/net company called zte and has only 2 lan ports fe and ge and the cable was plugged in the wrong port!
The goal is to connect this rpi3b+ with openHABian to the local network using its integrated WiFi chip! I tried already the steps described above (right after fresh openHABian install), tried also after accessing the openHABian-config and setting the right ssid and pass, save, reboot but there is no way make it work! I bought this new rpi3b+ only for this WiFi chip and its very frustrating that for some of the users is very simple to get it work and on the other hand every where you read on different forums there are tons of people facing this issue especially with this rpi model!

@ewgor I understand your goal and your frustration, but I don’t think you understood what I posted. I am recommending that you do not install openHABian and instead just install Raspbian Lite. Then, do the openHAB install. With my guide that I posted above, you will have it working the way you want within a short time.