Raspberry pi upgrade beta5 no starting

Hello,

I have upgraded my raspberry pi installation today.

Since this, openhab doesn’t start.

Here is my syslog error :

Dec 27 12:53:50 raspberrypi start.sh[5529]: Launching the openHAB runtime…
Dec 27 12:53:52 raspberrypi start.sh[5529]: Unknown constant tag 118 in class file java/util/regex/Pattern
Dec 27 12:53:52 raspberrypi start.sh[5529]: Error occurred shutting down framework: java.lang.ClassFormatError: java/util/regex/Pattern
Dec 27 12:53:52 raspberrypi start.sh[5529]: java.lang.ClassFormatError: java/util/regex/Pattern
Dec 27 12:53:52 raspberrypi start.sh[5529]: at java.lang.String.replaceAll(String.java:2223)
Dec 27 12:53:52 raspberrypi start.sh[5529]: at org.apache.felix.utils.properties.InterpolationHelper.unescape(InterpolationHelper.java:400)
Dec 27 12:53:52 raspberrypi start.sh[5529]: at org.apache.felix.utils.properties.InterpolationHelper.substVars(InterpolationHelper.java:235)
Dec 27 12:53:52 raspberrypi start.sh[5529]: at org.apache.felix.utils.properties.InterpolationHelper.substVars(InterpolationHelper.java:198)
Dec 27 12:53:52 raspberrypi start.sh[5529]: at org.apache.felix.utils.properties.InterpolationHelper.substVars(InterpolationHelper.java:132)
Dec 27 12:53:52 raspberrypi start.sh[5529]: at org.apache.karaf.util.config.PropertiesLoader.loadSystemProperties(PropertiesLoader.java:120)
Dec 27 12:53:52 raspberrypi start.sh[5529]: at org.apache.karaf.main.ConfigProperties.(ConfigProperties.java:203)
Dec 27 12:53:52 raspberrypi start.sh[5529]: at org.apache.karaf.main.Main.updateInstancePidAfterShutdown(Main.java:226)
Dec 27 12:53:52 raspberrypi start.sh[5529]: at org.apache.karaf.main.Main.main(Main.java:191)
Dec 27 12:53:52 raspberrypi systemd[1]: openhab2.service: main process exited, code=exited, status=254/n/a
Dec 27 12:53:52 raspberrypi stop[5689]: stop: Ignoring predefined value for KARAF_HOME

Has someone a solution ?

It s a test environment without much installed on it.

Thanks

What type of installation? Manual or apt-get? HASPBIAN?
How did you upgrade?

Sorry forgot to add this information.

apt-get install

usual apt-get update && apt-get dist-upgrade

It’s a raspian

r oot@raspberrypi:/home/pi# cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)"
NAME="Raspbian GNU/Linux"
VERSION_ID="8"
VERSION=“8 (jessie)”

Thanks

“Unknown constant tag” errors in class files are often caused by damaged class files (in this case: java.utils.regex.Pattern). Mmaybe a problem with the SD card?
You could try to remove Java installation and install it new.

Seem’s you were right about sd card.

I had corrupted archive of java when re installing it

And now I have launched a reboot and it seems it’s not coming back.

I’ll see when I will be home later.

Thanks