Raspi 4 install - SAMBA access to "openhab2-share" folder

Tags: #<Tag:0x00007f617e2016b0> #<Tag:0x00007f617e201458>

I just installed Openhab 2.5.5 via openhabian package install on my new Raspi 4.
I now want to add JAR files into the addon folder … but I can not access it via SAMBA on my Win10 machine.
this is how it looks for the PI4:

for the old PI3, it looks like this:

what did I do wrong on the PI4?

have a look into the content of the file /etc/samba/smb.conf.

big thanks … the folder was commented out.
Now I can access it correctly from within Windows

Why would you want to access it ?

See above, I need to copy JAR files for openhab addons into the addons directory. In my example, it is the IPCAMERA binding.

Ok, but as that can also (and IMHO should also rather) be done on the box via Karaf console or directly, I don’t see that to be a reason why we should (re)enable that per default for everybody.
You can enable it yourself, of course.

Fortunatly he never said that or even asked for it.

1 Like

I understand. No problem. I enabled it and added the files. System is working fine.
I keep documentation, backups, configuration and addon files on my synology server and working with the windows frontend is easier for me.

@mstormi shouldn’t the addons and backup folders be readily available?

addons - no, why would you want to access that from windoze? You still can on the box.
backup, it’s still there, below userdata

To be able to copy downloaded bindings

sure, but there’s multiple more ways to do that, and it’s no good idea to start them just by copying a file there, better use Karaf console or login to the box.