Raspi-config Command not found

Tags: #<Tag:0x00007f433dd79cb8> #<Tag:0x00007f433dd79bf0>
  • Platform information:
    • Hardware: Raspberry pi 3B+
    • OS: OpenHab 3.0.1 Release Build
    • Release: Raspbian GNU/linux 10 (buster)

Good day all.

So I am trying to get GPIO binding working on my openhab in order to control relays that are connected to outlets for my aquarium.
In openhab 2.. everything was working great with rules and timers.

Now, at least from what I’m reading, I need to enable an option in raspi-config to allow openhab access to the the GPIOs.

However, when i try to run raspi-config i get “command not found”. I can’t even log in as User: pi PW raspberry.

Any help would be more than appreciated. Thank you.

if you used openhabian for installation, I believe raspi-config was not included because it created a conflict. You can still download, install and use. I’m sure there are manual method for giving permission to use gpio

2 Likes

Thank you for the reply.
Do you know the way to manually install raspi-config??
Edit: I think I got it
sudo apt install rpi-imager

Edit 2: ok so I installed raspberry pi OS and it still wont register the command or let me log in as User:pi PW:raaspberry

1 Like

sudo raspi-config
username: openhabian

It doesnt ask for a username to use that command, only a password. (which is my openhabian password)
I use it, and the command line still says “command not found”

You can install raspi-config. But be very careful what you do with it and realize your system is not the same as the system from the maintainers, making it harder for them to help you.

sudo apt-get install raspi-config

1 Like

there is an alias defined in .bash_profile in your home directory. try deleting this alias:

if [ ! -f "/usr/bin/raspi-config" ]; then
  alias raspi-config="echo 'raspi-config is not part of openHABian, please use openhabian-config instead.'"
fi

and make sure that raspi-config is owned by openhabian

You should not need to change options for GPIO if you are on openhabian.
So also no need to install raspi-config.

ok so I have most of it working I think (I still cant get things to load on openhab3 dashboard but one thing at a time i guess).

so after a reboot im getting:

Warning: The unit file, source configuration file or drop-ins of pigpiod.service changed on disk. Run ‘systemctl daemon-reload’ to reload units.
● pigpiod.service - Daemon required to control GPIO pins via pigpio
Loaded: loaded (/lib/systemd/system/pigpiod.service; enabled; vendor preset: enabled)
Drop-In: /etc/systemd/system/pigpiod.service.d
└─public.conf
Active: active (running) since Sat 2021-04-17 19:07:02 EDT; 2min 57s ago
Process: 421 ExecStart=/usr/bin/pigpiod (code=exited, status=0/SUCCESS)
Main PID: 428 (pigpiod)
Tasks: 4 (limit: 2181)
CGroup: /system.slice/pigpiod.service
└─428 /usr/bin/pigpiod

Apr 17 19:07:01 openHABianDevice systemd[1]: Starting Daemon required to control GPIO pins via pigpio…
Apr 17 19:07:02 openHABianDevice systemd[1]: Started Daemon required to control GPIO pins via pigpio.

should i be concerned or continue with the tutorial?

so the issue is I can’t install the standard GPIO binding in openhab3 dashboard. it says I have the option to install 252 bindings and that’s it. I have a 1-wire GPIO option for sensors but nothing to control the GPIO on/off remotely.

Are you using the new gpio binding?
https://community.openhab.org/t/gpio-new-gpio-binding-for-oh3/113943

Since you didn’t even explain what tutorial you are following, how am I supposed to know ?

Yes I am. I have followed this tut and still nothing

The tutorial by Openhab team themselves. I’m still not having any luck.
I did a fresh install and still nothing
(sorry for the late replay, been flying a lot with work)