RaZberry2 OpenHAB2 Bridge_Offline

Tags: #<Tag:0x00007efebfe70fa8> #<Tag:0x00007efebfe70ee0>

Hello,

i managed to install and setup OpenHAB2 on my Raspberry Pi 3 with OpenHABian 1.1. I installed the RaZberry2 on the GPIO pins and configured the path to /dev/ttyAMA0 (i also tryed /dev/ttyS0).

But my controller is still offline. I get die status “OFFLINE - BRIDGE_OFFLINE Controller is offline”.

When i start the Pi the leds on top of the RaZberry begin to flash. Then after 1 to 2 seconds the go off.

I read all posts i could find with RaZberry and “Offline” but all of them are about “/dev/ttyAMA0 does not exist”. This is not my problem.

Any ideas how i can get the controller online?

I hope someone can halp me.

Thanks
Nils

I have ordered the second RaZberry and an UZB Stick.

The stick works just fine. It is online and i can add Things.

The second RaZberry just dont work either. Do i have to install some software or make some settings to get it to work?

Thanks
Nils

Did you execute the steps in sudo openhabian-config specifically meant for devices like the Razberry? https://github.com/openhab/openhabian/issues/33#issuecomment-267465644

Yes. I select all three options (found this on an other site ).

After I have selected the second option the “does not found” message disappeared and the “Bridge_Offline” status appeared.

Others were able to get their Razberry working. Please check for messages in the main openHABian thread.

Sorry but what do you mean with main thread?

Sorry, this one:

I got it working.

I deselect the second option under “Serial Port” and used the port “/dev/ttyS0”. My RaZberry is now online and find my z-wave Things.

hi @NilsAcht,

Glad that it worked for you. Sadly, this is my third day without no success.
Firstly, my set up:

  • Raspberry PI 3 B
  • OpenHAB 2.1
  • Z-Wave Me RaZberry module – ZME _ Raz _ EU

I’ve installled the RaZberry module using the instructions from razberry.z-wave.me ()

This is what I’ve tried so far:

  • Disable Bluetooth port on /boot/config.txt => DONE
dtoverlay=pi3-disable-bt
```
Also tried with:

dtoverlay=pi3-miniuart-bt


- Disabled serial ports on sudo openhabian-config => DONE 
(Also play a little with different variations of enabled/disabled options.)

[] 1 (RPi) Disable serial console (Razberry, SCC, Enocean) │
[
] 2 (RPi3) Disable Bluetooth module (Razberry) │
[*] 3 Add common serial ports to openHAB JVM (Razberry, Enocean) |


- Update, upgrade, etc => DONE

sudo apt-get update
sudo apt-get upgrade

As well as the updates/upgrades from openhabian-config

- Set user groups (openhab to dialout/tty, for instance) => DONE

crw-rw---- 1 root dialout 204, 64 Jul 2 01:07 ttyAMA0
crw-rw---- 1 root dialout 4, 64 Jul 2 01:01 ttyS0


- Make sure the ports are set on the serial port's list => DONE
- Try ttyAMA0 and ttyS0 => DONE

Like you, I dont get "/dev/ttyAMA0 does not exist", but simply the bridge remains offline.
When going to the inbox and tryig to discover things, I get this logs:

==> /var/log/openhab2/openhab.log <==
2017-07-02 01:07:25.751 [DEBUG] [ocol.ZWaveController$ZWaveSendThread] - NODE 255: Timeout while sending message. Requeueing - 1 attempts left!
2017-07-02 01:07:25.752 [DEBUG] [ve.internal.protocol.ZWaveController] - Message queued. Queue length = 2. Queue={}
2017-07-02 01:07:25.771 [DEBUG] [ocol.ZWaveController$ZWaveSendThread] - Took message from queue for sending. Queue length = 1
2017-07-02 01:07:25.773 [DEBUG] [wave.internal.protocol.SerialMessage] - Assembled message buffer = 01 08 00 54 01 00 00 00 01 A3
2017-07-02 01:07:25.776 [DEBUG] [ing.zwave.handler.ZWaveSerialHandler] - NODE 255: Sending REQUEST Message = 01 08 00 54 01 00 00 00 01 A3
2017-07-02 01:07:25.786 [DEBUG] [WaveSerialHandler$ZWaveReceiveThread] - Receive Message = 01 04 01 54 01 AF

And several of this:

2017-07-02 01:24:28.590 [DEBUG] [WaveSerialHandler$ZWaveReceiveThread] - Protocol error (OOF). Got 0x07


This is driving me insane, any help?

Ok, I got it ONLINE.
I’ve started anew with a clean OpenHABian instalation, and unselecting the 2nd option on the serials ((RPi3) Disable Bluetooth module), and setting the port to /dev/ttyS0.
BUT: It doesn’t detect any device.
Also, the z-wave.me suite has stopped working, saying:

 An unexpected error occurred while initialising the Z-Wave controller data.
Please check 
1.) if the controller is plugged in correctly, 
2.) that in the app 'Z-Wave Network Access' the right port is entered 
(UZB: '/dev/ttyACM0', Box: '/dev/ttyAMA0', UZB-Windows: '\\\\.\\COM3', Z-Stick: '/dev/ttyUSB0', embedded boxes: '/dev/ttyS0' or '/dev/ttyS1') 
3.) the app is aktiv. If not you could activate it under Menu > Apps > Activ or add a new one under Menu > Apps > Local. 
The Setting 'Expert View' needs to be active under Menu > My Settings.

I’ve tried what it says it needs to be done but no success :confused:

Hello @fechy,
you need to select all three options, then reboot your system. I don’t know why this would suddenly not work.

Why are you using it? Did you think about the possibility that they are conflicting each other?

Did you think about the possibility that they are conflicting each other?

No, didnt cross my mind :confused:

Why are you using it?

Came when installing z-wave.me like:

wget -q -O - razberry.z-wave.me/install | sudo bash

you need to select all three options

Did now, and still working. got to change the port to /dev/ttyAMA0 again.

Still, I cant find any of my devices. And adding manually only offers me to add a Z-Wave Serial Controller