RC1 on Raspberry Pi3 /and Windows

I thought I would give RC1 on my raspberry pi 3 a try. This was running the last snapshot version. I did the following:

a) uninstall openhab as per documentation:

sudo apt-get purge openhab2*
sudo rm /etc/apt/sources.list.d/openhab2.list

b) updated repository

echo 'deb http://dl.bintray.com/openhab/apt-repo2 testing main' | sudo tee /etc/apt/sources.list.d/openhab2.list

c) Install

sudo apt-get update
sudo apt-get install openhab2

d) Start

sudo systemctl start openhab2.service
sudo systemctl status openhab2.service

sudo systemctl daemon-reload
sudo systemctl enable openhab2.service

e) Selected Standard System, installed my bindings, set sitemap to ‘home’ and copied my configuration files across.

f) Browsing to the UI gave a site not found error but a sudo reboot corrected this.

My main binding is MQTT and that works but I had to uninstall it and reinstall it to get that going. However, I’m having problems with the following bindings:

  1. NTP: I can’t get the datetime through ntp as used by the demo configuration

  2. ASTRO: This doesn’t work. Files exactly the same as the demo configuration

  3. Weather: Gets correct weather details in items but get the following when using example.html:

javax.servlet.ServletException: File with weather layout ‘example.html’ does not exist, make sure it is in the layouts folder ./webapps/weather-data/layouts

There is no reference to ntp or astro in the openhab.log.

I also got exactly the same results running RC1 on my windows PC. Interestingly (have only tried this on windows), if I select demo (rather than Standard), change the sitemap to ‘home’ and replace the demo files with my home files, the NTP and ASTRO work. Weather via example.html doesn’t.

Do the problem bindings show as installed in PaperUI?

Yes and they were all installed using PaperUI. I’ve also tried uninstalling and installing them.

How old of a version did you upgrade from?

There might be some sort of corruption in your userdata folder due to changes that have been made since your previous install or something went wrong with the upgrade.

You can make a backup of your userdata folder (/var/lib/openhab2), stop openhab, delete the contents of the cache and tmp folders and then restart OH.

You might need to reinstall your bindings after this but it should clear out any corruption that would be there.

Alternatively you can start over completely fresh by deleting all the contents of the userdata folder. This will reset everything back as if you had a fresh install instead of an upgrade.

I have found the cause and I’m rather embarrassed. There was no ‘home.things’ file in the things directory to define the ntp and astro.

Very sorry for wasting your time or anyone else’s time, It’s a long time since I touched that file so didn’t realise it was needed.

Glad you found the solution. This thread was not a waste. Others will find it and it will help them solve their problem.