Recovering from Hard reset

I am using OpenHabian on a Rpi3 B+ running the 2.5 snapshot. All of my devices are all ZWave devices. It was working well for a long time but then one day I was in HABmin and I was going to re-add a device and instead of clicking ‘Exclude’ I clicked ‘Hard Reset’. That’s when everything went wrong and all my devices were no longer on the network. I have been trying to get them re-added to the network, but I am having a lot of struggles. I am currently on 2.5.0~S1596-1 version of OpenHAB and I am using the most recent snapshot of the ZWave binding. I am trying to get the devices re-added but I can’t get them to link up. I have tried excluding them, then adding them, but they never show up in the HABmin or Paper UI. I look in the logs but there’s nothing in the logs to really go off of to help me troubleshoot. Can anyone provide some guidance to help understand the easiest way to re-add the devices to my network. If there’s anything I can provide to assist, please let me know. I would include the logs, but like I said, nothing gets generated so I am not sure what good they will do.

Something else that’s strange, but I am not sure if it’s related is that when I go into discovery mode the responsiveness of OpenHAB slows way down. That is, when it goes into discovery mode I will click on a device to turn a light on and it will take around 10-15 seconds before it actually turns the light on or off. If I reboot the controller completely and let it come back up, it works normally where it will turn the light on or off instantly. Again, nothing in the logs indicating any error on why it’s doing that or why a reboot fixes it.


Have you also told the device to enter exclusion (usually the same as inclusion)? But after a hard reset of the controller, you could also just hard reset the devices and that usually clears their network.

Thanks for your response Scott! I have put the device in exclusion mode at the same time, but I am not sure if the exclusion is actually doing what it’s supposed to. I expected some sort of message or log entry to show up that would confirm that something happened, but I don’t.

Any thoughts on why the controller becomes less responsive?

I’m on S1595, but I haven’t tried zwave inclusion in a long while. Discovery for other devices does not seem to cause an issue, but I definitely see higher load on the server running OH. That may cause issues on a Pi. Use top to see what your load is. I’m seeing about twice as much as what I normally do.

You should see debug logs when exclusion is started and when a device is excluded. Have you set the log level to debug for the binding?

It appears that I will have to do the factory reset as that is all that seems to make this work correctly. It isn’t the best thing since I have to open up some walls to access the devices, but nothing else seems to work. Thanks for the suggestion @5iver, at least this works for now. Word to the wise, be careful not to click ‘Hard Reset’!!

I kind of remember mentioning this to @chris. It would be a nice feature to be prompted for confirmation of the hard reset, if that is possible. Or some double action, like another option is exposed to confirm reset.

I’m not sure if there is such concept in the configuration definition. I think we discussed adding a “critical” flag to ESH, but I’m not sure if this was done or not?

I just checked - it was finally added but the name got changed from critical to verify.

I can add this to the parameter definition, but of course unless this is implemented in the UI, nothing will actually change.


I have been working on reconnecting a new device since I did the hard reset. It is a Kwikset 888 deadbolt. The issue I have is that I am trying to get it added back to the network, but it won’t get fully added to the network. I can get it to show up in HABmin, but not all the properties are available and it won’t lock/unlock the device. I posted a ticket to @chris on as I thought it was a binding issue. What he was able to see is that the device is not securely being included on the network. Unless it securely connects it won’t function correctly. I have tried doing a factory reset on the device and re-initializing it. It re-joins, but it won’t securely include. @chris said that the device isn’t actually being removed because when it get’s re-added it gets added with the same Node number as when it was previously included. In my case it is assigned Node #7. Then I do the following steps:

  1. Delete the Thing from HABmin
  2. Put the controller in Exclusion mode via HABmin
  3. Push the button on the device to exclude it from the controller
  4. Perform the factory reset on the device
  5. Put the controller in discovery mode via HABmin
  6. Push the button the device to include it on the controller
  7. Once it shows up in HABmin in the Inbox click the Add button

After performing these steps it shows up in HABmin still as Node #7 and it is still non-securely included in HABmin.

@chris said that I need to have it be assigned a new node number so that it goes through the initial inclusion as that is the only way to get it added securely.

Can you recommend a way to force HABmin to remove this device from the controller so it will get a new Node number and get included securely?

I have tried similar steps using Paper UI and it has the same results.


Try adding the node number to your “ignored” section in your inbox. It sounds to me like the device is not excluding properly and/or it is not being seen during the new secure inclusion (distance from the controller possibly a factor?).

How much time are you allowing to elapse between these steps, and does the log say that there was an exclusion?

I messed around with this for another day and then I had to give up. No matter what I did, I could not make it get a new Node ID. So I pulled the microSD card, put in a new card with a fresh 2.5 install and the device included without any issues. The other issue with delayed response also went away. I am not sure what about the hard reset made this go sour. I will probably just migrate my stuff from the old setup to the new setup and go from there. Thanks for everyone’s input. I know this seems like a “scorched earth” solution, but it seems like its easier than trying to track down a needle in haystack.

1 Like

I am in the exact same boat. I was trying to add an 888 kwikset and in all my frustration I ended up doing the hard reset and i lost all my devices. I am just going to wait for the next stable release and start a new. I think the “Hard Reset” should be renamed with “Factory Reset” or add prompts to warn users that all devices will be lost.

I don’t know if there is an issue with the 888, but no matter what I tried I could not get it included securely. I had one working once before (which was also a huge headache and ended up working by luck???) but the batteries would only last about a week. So I replaced it and I am in a worse position now from doing the “Hard Reset”

Did you end up getting your 888 to work stably after a fresh install?