Reflash MAX! cube to CUNx

Any particular reason why you didn’t stay with that ?

Which thermostat and window contact devices did you choose ?

Yes, slow response from Max! devices and I wantet to optimize my system, reducing used technnologies. As I already had Z-Wave smoke detectors and some socket plugs, I moved over to Z-Wave.
Now I am basically using Z-Wave, Shelly and a few digitalSTROM devices.

I bought Eurotronic Spirit thermostats, windows sensors are replaced with Fibaro sensors plus i am experimenting with Sense Stripes. Terrace door conact was replaced with Philio 4in1, giving also motion detecion for my livingroom…

Hi, first of all my thanks for this awesome work. I’m trying to save my “old” Max Cube thermostats with this.

  1. Flashing the Cube was succesfull.
  2. But I have problems setting up Homegear. Followed the instructions on the homepage but couldn’t figure the full configuration out.
  3. I connected the cube to my, receiving an IP-adress.
  4. Installed homegear on my ubuntu server which is runnung nextcloud with SSL.
  5. When I start homegear I get messages that port 80 is already in use.

Can anyone help me?

It may actually be in use, port 80, depends on what else is running on this machine.

To find out the service usig the port you can use nmap tool.

sudo apt install nmap
sudo nmap localhost

It will list open ports.

To resolve the issue i would use diferent port for homegear.
I guess that the homegear has a setting to change http port to new custom port.

I was thinking someday of flashing Max Cube but i was unsure of bricking it. If your project succeds it may actually be good news.

I dont use homegear yet but i know it has webserver on port 80.

I asked chatGPT where to change port 80 on homegear.

To change the port used by Homegear, you will need to edit the configuration file.
On a Linux or Unix-based system, the file can typically be found in the /etc/homegear directory.
The configuration file for Homegear is an INI file.

Here is an example of what the file might look like:

ip =
port = 80

ssl = false
bindToInterfaces = true

myDevice1 = 1
myDevice2 = 2