Regarding Debugging Homematic IP: no updates on some HmIP devices after some time


I had to uninstall and re-install the bundles with karaf console and delete some stuff from tmp-folder. Took a while but now they are history. Intead the exceptions are gone.
I added new traces. (107.3 KB)
Initially all items are filled correctly from CCU3, but at 09:45:34.278 I switched off a power switch HomematicBinding_BrunnenSwitch but the item HomematicBinding_BrunnenPower get never updated a recation on that.
Is there any way to work around that problem?


Hallo Gerd,

some questions: did you receive earlier updates from the switch?

I can see the event in openhab.log

2021-10-25 09:45:34.282 [DEBUG] [ternal.handler.HomematicThingHandler] - Received command 'OFF' for channel 'homematic:HmIP-FSM:3014F711A0001F9A498978DA:00089BE98AC8C9:2#STATE'

The binding received an event. But nothing happened according to openhab.log.

But I am not sure whether this event was created from OH or whether it was received from the CCU (need to check the implementation).

If the binding does not receive any updates from the CCU please also check the port settings according to the documentation (all mentioned ports must be open in the firewalls). Also make sure that OH is reachable from the CCU. I have seen that OH and the CCU are in different networks.

Please check your item definition and maybe create it anew. It is possible that the something was damaged during your re-install.

If everything looks OK, please set the log level to TRACE and switch on/off the power switch itself.

I will try to answer the questions:

This time I switched off from Paper UI. Worked fine.

You said “Paper UI”. Do you have an OH 2.5 installation in parallel? This will cause problems with binding version 3.1 and 2.5.

If this way works but not the other way round, you probably have either a problem with ports blocked by a firewall or a routing problem.

I use only one network. Where do you see that?

I can see it from the IP addresses: the gateway address is and the callback Host (= OH) is These are different logical networks. The respective entry in UI is empty, I don’t know where it is comming from.

If the machine where OH is installed has more than one IP address, OH choses one as a default address. Sometimes this is a wrong address and causes problems. In this case you should set the callback host address explicitly in the bridge configuration. Probably this wrong address is the cause of your problems.

Thank you very much for the wealthy support.

1 Like

Good to know that it is working now.

I have added a hint to the troubleshooting section of the binding documentation. I don’t think that is possible to display to selected default address in the callbackHost field.
But you can see the default IP address under Settings/Network Settings in Main UI.