Relayboard state "ON" on startup

Hi everyone,

I have an OH environment on my raspi3 with a GPIO binding for control remotely a relayboard. I crawled into the openhab documents page for some info but i didn’t found a solution for my problem.

When the pi is booted and OH is running, all my contacts on my relayboard are activated. I tried to reverse my switches by adding ‘initialvlue:low’ and activelow:yes but the all the leds on my relayboard are “ON” each startup.

Kind Regards,

You need to do initialvalue:low and activelow:no - I think…

Hi, when I add the “initialvalue” parameter to the switch item, the realyboard doesn’t interact anymore. When log the events.log, I see that the state changes, but nothing happens with the relayboard.

Then I was wrong…
{ gpio="pin:2 activelow:no initialValue:low" }
For example, in the same order

Hi, thanks for your fast reply. It didn’t work for me. The switch only works if i leave the initialValue parameter.
But then the relay is still activated each boot up.

Then do it with a rule

rule "system start"
    System started

I can see in my eventlog that the switch is turned off (by the rule) from “NULL TO OFF.”, but one minute later it the state changes (automatically) from OFF to ON.

So the rule is too early I think. Is this normal that the switches are turned automatically ON by default?

Someon who can help?