Release Candidate and Support: Amazon Echo Control Binding

Tags: #<Tag:0x00007fc9103ccdd8> #<Tag:0x00007fc9103cc6a8> #<Tag:0x00007fc9103cc4c8>

Did you provide your credentials for your Amazon account?

Yes. I also double checked the credentials, they are correct.

When I start openHAB on a different Host (Windows Workstation), the binding works without any problems. The error only occurs on my openHAB server (based on Ubuntu). So I think there is no problem with my account or the credentials.

Has anybody a hint on how to troubleshoot the error? All other bindings are working fine on the ubuntu server.

Thanks and kind regards

David

did you try to enter your crendentials using http://YOUR_OPENHAP/amazonechocontrol/ID_OF_THIS_THING i needed to do this on debian because otherwise it wouldn’t connect for me too

Hello,

for me the same, than DavidB.
This link http://YOUR_OPENHAP/amazonechocontrol/ID_OF_THIS_THING doesn´t work, too.
But the thing wasn´t created. First with error 500. After a second try, with 409, conflict error.

I also tried a complete reboot. I guess, there is something wrong with this binding in combination with OH 2.3 RC1.

Sebastian

Hi,

thanks for your reply. I can access this link, but I’m not able to enter any credentials. The error above (No session id received) is shown on that page.

In my openHAB log, there is an error regarding a plugin with the version 2.4.0.*:

2018-06-03 19:46:15.743 [ERROR] [rg.openhab.binding.amazonechocontrol] - FrameworkEvent ERROR - org.openhab.binding.amazonechocontrol
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.amazonechocontrol [266]
  Another singleton bundle selected: osgi.identity; type="osgi.bundle"; version:Version="2.4.0.201806030817"; osgi.identity="org.openhab.binding.amazonechocontrol"; singleton:="true"

I’m on openhab 2.3 stable. Any ideas, why 2.4 ist mentioned?

Thanks

David

just a guess, do you have the binding installed in your addon folder as well as using paperUI?

also did you already tried deleting the cache?

1 Like

is there a specific reason you are still running OH 2.3 RC1? if not updating to openHAB 2.3.0-1 (Release Build) might be worth a try

Yes, i put the file in the addon folder during troubleshooting. Not sure if the message started at that point.

But clearing the cache did the job! Now everything is working fine.

Thank you very much. You made my day! :slight_smile:

And thank you for the binding. I love it!

Greets

David

1 Like

I’m getting the same error. First time install of the binding on OH 2.4.0 snapshot 1293. Clearing the cache didn’t help. I had two factor authentication when I first set up the Account Thing, but I’ve deleted the Thing and removed two factor auth. Is there a cookie being used?

is there a specific reason you are still running OH 2.3 RC1? if not updating to openHAB 2.3.0-1 (Release Build) might be worth a try

There is no reason. This is the version, that was offered to me during apt-get update / upgrade.

sebzim@openHAB:~ $ apt-cache policy openhab2                                                                                                                                                                       
openhab2:                                                                                                                                                                                                          
  Installed: 2.3.0.RC1-1                                                                                                                                                                                           
  Candidate: 2.3.0.RC1-1
  Version table:                                                                                                                                                                                                   
 *** 2.3.0.RC1-1 0                                                                                                                                                                                                 
    100 /var/lib/dpkg/status                                                                                                                                                                                   
 2.3.0-1 0                                                                                                                                                                                                     
    500 https://dl.bintray.com/openhab/apt-repo2/ testing/main armhf Packages                                                                                                                                  
 2.3.0~RC2-1 0                                                                                                                                                                                                 
    500 https://dl.bintray.com/openhab/apt-repo2/ testing/main armhf Packages                                                                                                                                  
 2.3.0~RC1-1 0                                                                                                                                                                                                 
    500 https://dl.bintray.com/openhab/apt-repo2/ testing/main armhf Packages                                                                                                                                  
 2.2.0-1 0                                                                                                                                                                                                     
    500 https://dl.bintray.com/openhab/apt-repo2/ testing/main armhf Packages                                                                                                                                  
 2.1.0-2 0                                                                                                                                                                                                     
    500 https://dl.bintray.com/openhab/apt-repo2/ testing/main armhf Packages                                                                                                                                  
 2.0.0~RC1-1 0                                                                                                                                                                                                 
    500 https://dl.bintray.com/openhab/apt-repo2/ testing/main armhf Packages  

Normally, the latest version should be installed during update / upgrade process, right?

Got it running. I had “downgrade” to OH 2.3.0-1
With my RC1 version, it was not running.

Thanks for help.

1 Like

I’m currently using TFA on my Amazon account and would like to use this binding. Is it technically possible to use the API using a user created application token instead of username/password?

.

Since this morning my Amazon Account Thing is offline:

Status: OFFLINE - CONFIGURATION_ERROR Login fails. Check your credentials and try to login with your webbrowser to http(s)://youropenhab:yourport/amazonechocontrol/echo1 Wichtige Mitteilung! Zum besseren Schutz Ihres Kontos geben Sie bitte nochmals Ihr Passwort ein, und geben Sie dann die Zeichen ein, die in der Abbildung unten gezeigt werden.

It seems Amazon is asking for something like a captcha, but where to call that captcha page?

http(s)://<youropenhab:yourport>/amazonechocontrol/echo1 does show:

1

but a click on “Amazon Account” does not load any page … same for

/amazonechocontrol/ and /amazonechocontrol/account

openHAB snapshot 2.4 #1292

Sorry, currently not.

1 Like

Hi Mark,
I think this is the wrong thread for your question. I assume your question is about alexa skill or a other binding, but it seems not related to the amazon echo control binding.
Kind regards, Michael

I know that there is somewhere a description on the amazon page how you can enter such a token in apps which does not support 2 factor authentication. But I think it will not work for the session renew required after some days.

Maybe it does not work with 2.4. I am currently very busy, so I can not test it in the moment.

What are the next steps

Currently I’am very busy (there are a lot of weddings and other work), so I have no time for OpenHAB.
This also means, that I will not give many support in this thread in the next time. Sorry!

But the good news, I will continue the development in autumn. The plan is to implement a MQTT connection to the amazon server to get live update for state changes from the echo devices. This would remove the polling I will be able to provide a new channel which gives feedback for the last spoken command to the echo device.

Best Regards,
Michael

2 Likes

Never mind, a server restart fixed it …

Hi Michi, You are quite correct. Sorry. I think I confused myself and need to slow down :rofl: