Release Candidate and Support: Amazon Echo Control Binding

Sorry, it‘s Beta 5 :wink: Thank you for the hint.

1 Like

haha ok thanks

Hi Guys,

Just wondering if anyone else has seen this issue? Since installing 2.5(3) TTS is broken, and now since installing 2.5(4) Volume control is also broken. Just to rule out if it was caused by something else in my configuration I set up a fresh openhabian 2.4 install with only the echo control binding install on a separate RPi and both items worked until I restarted openhab. Does anyone have any ideas?

org.openhab.binding.amazonechocontrol.internal.HttpException: POST url ‘’ failed: Bad Request

at org.openhab.binding.amazonechocontrol.internal.Connection.makeRequest( ~[?:?]

at org.openhab.binding.amazonechocontrol.internal.Connection.executeSequenceNode( ~[?:?]

at org.openhab.binding.amazonechocontrol.internal.Connection.executeSequenceCommand( ~[?:?]

at org.openhab.binding.amazonechocontrol.internal.handler.EchoHandler.handleCommand( ~[?:?]

at sun.reflect.GeneratedMethodAccessor131.invoke(Unknown Source) ~[?:?]

at sun.reflect.DelegatingMethodAccessorImpl.invoke( ~[?:?]

at java.lang.reflect.Method.invoke( ~[?:?]

at org.eclipse.smarthome.core.internal.common.AbstractInvocationHandler.invokeDirect( [102:org.eclipse.smarthome.core:]

at org.eclipse.smarthome.core.internal.common.InvocationHandlerSync.invoke( [102:org.eclipse.smarthome.core:]

at com.sun.proxy.$Proxy164.handleCommand(Unknown Source) [189:org.openhab.binding.amazonechocontrol:2.5.0.Beta_05]

at org.eclipse.smarthome.core.thing.internal.profiles.ProfileCallbackImpl.handleCommand( [109:org.eclipse.smarthome.core.thing:]

at org.eclipse.smarthome.core.thing.internal.profiles.SystemDefaultProfile.onCommandFromItem( [109:org.eclipse.smarthome.core.thing:]

at sun.reflect.GeneratedMethodAccessor130.invoke(Unknown Source) ~[?:?]

at sun.reflect.DelegatingMethodAccessorImpl.invoke( ~[?:?]

at java.lang.reflect.Method.invoke( ~[?:?]

at org.eclipse.smarthome.core.internal.common.AbstractInvocationHandler.invokeDirect( [102:org.eclipse.smarthome.core:]

at [102:org.eclipse.smarthome.core:]

at [?:?]

at java.util.concurrent.ThreadPoolExecutor.runWorker( [?:?]

at java.util.concurrent.ThreadPoolExecutor$ [?:?]

at [?:?]</code>


It does . . . Thanks again Michael!

Best, Jay

Hi Michael,

Testing since yesterday on OH 2.4 on arch, all good so far despite various internet outages.

Question: I am trying to assess if the Echo is available or not through a script (idea is for instance to redirect notifications in case of unavailability, or to send a mail), unfortunately the Echo Thing appears online even if the Echo is not (I tested by powering it off, the Echo Thing keeps on indicating that the Echo is online which is obviously not true). Do you believe there would be a way to grab the real status of the echo?



Open the binding web page
click on the account
check if the correct state is shown there

If so, it would be possible, but I’am not sure if there is a notification for state change, so maybe a polling is needed.

Or you make an REST call through the binding reverse proxy in your rule before you sent the notification.

Best, Michael

Yes, I expect you have multiple amazon accounts where the echo is registered. But anyway this should be resolved already. But there was an issues in an old beta which did not grap the correct customer id from the account. Please try go to the binding web page
Click on the account
Click on ‘Logout and create new device id’
Relogin to your account

Maybe this helps, but I’am not sure. If not, please try to use the other amazon account for the device.

Hi Michael,

All my echo’s are only registered to one account so not sure what happened there :thinking:
Logging out and creating a new device ID fixed it though :grinning: Thank you



Hello Michael,
I can report that with the beta 2.5(5) i now can see the Image and progress info, (Song, Album, Time played etc), and no errors in the log! :smile: was that an intention in this release already?
Again, love this binding, keep up the good work!

@michi kind reminder for my questions in post #1503 :slight_smile:

Hello Michael,
I have 10 Xiaomi temp/humid sensors, which i tagged with [ “CurrentTemperature” ] and this works with Alexa, first she answered, “The bedroom temperature is 20.9597467863262675 degrees”:joy:, a bit to exact!
But with some help from our OH friends and a “rounding” rule that also works now, so it is not an Alexa problem i think.

I´m going to create a new thread as it doesn´t seems to be a homekit or Alexa binding problem…

Hi Ray!
Can you share this rounding rule?

As long as you don’t ask me how it works! :grinning:

rule “Round Temperature Livingroom Sensor”
Item HT_Temperature_LR received update
if (HT_Temperature_LR.state != NULL){
val roundedNumber = (Math::round((HT_Temperature_LR.state as DecimalType).floatValue()* 10)).floatValue() /10


The question is not rekated to the binding. Please sesrch for the openHAB Alexa skill.

Hello Michael,

I also have an Fire TV stick, and added it as an “Echo Thing” it comes online, and reports the following Capabillities, if you need more info, let me know


Curious. I am plannning on setting up my Echo devices this weekend. I see this binding and one from digitaldan.

Are these the same? One provide functionality the other doesn’t?

And one other. The binding that’s included with the OpenHAB install that can be installed,which one is that?




I’m having trouble with all of my echo devices with a screen i.e echoshow and echospot. I’m unable to get them to be recognized as “Things” using these item types

Thing file

Thing echoshow  echo3 "Alexa (Front Room echo3)" @ "Alexa" [serialNumber="abc"]

If I change all screen devices to an item type of “Echo” then a thing is created for them. With this change I can use TTS with no issues but i’m unable to get the lastVoiceCommand event to fire.

BTW - I’ve used the Alexa control from the bindings in openHAB. I’m not sure if this is the correct version I should be using ? I’ve seen references to using a “manually downloaded version” but I’m not sure how to install it manually.

Any ideas ?

Please read through these articles. It’s easy to confuse the two, but they have very different functionality. Actually, I threw in a third one, which is basically a limited functionality alternative to the skill, and keeps the commands local.

Amazon Echo Control

Alexa Skill

Hue Emulation

I believe they are all included in the OH 2.4 stable release, but this binding and the Hue Emulation have had significant fixes since then. IDK about the Alexa Skill, since I don’t use it. This binding is available as a manual install from the first post. Hue Emulation fixes are available in the OH 2.5 M1 release, or by using a manual install of a snapshot build of the binding.

Hi Michael,

Stability of the beta 5 is confirmed, no more thread leakage after two days of a bad connection. Regarding the status, no luck, the binding web page sees the same (ie Echo flagged as online despite being off). I’ll investigate to see if there is any other means to confirm Echo is online or offline.



1 Like