Release Notes for OH2 2.4 / hint for milight configuration


(Ducker2) #1

Hi! I do have milight things configured using things file and upgrading to milight binding version 2.4 requires to take this file await for a moment to have the database contents recreated. Otherwise the things are reported “Online”, but actually no commands are send to the devices. Error message in log file: [milight.internal.protocol.QueuedSend] - Failed to send Message to ‘xxx.xxx.xxx.xxx’: Socket is closed. Restarting OH2 has no effect and does not fix the error.
Just removed the things file for a moment and all works fine again.


(Rich Koshak) #2

You can write a System started Rule perhaps.


(David Graeff) #3

FYI: There are some fixes already in for OH 2.5.


(Ducker2) #4

Thanks for your feedback! Good to know that it’s already fixed in OH 2.5. Also for OH 2.4 it is not a real problem as once the recreation of database entries has been triggered (by removing the things file) the issue is solved. My intention was more to save some time for others facing the same issue after upgrading to OH 2.4.
@rlkoshak: can I use a System started rule to influence handling of static config files? Nevertheless my issue is solved I am willing to learn more about OH details. :slight_smile:


(Rich Koshak) #5

Well, you solution was to move the files out and move them back so in a system started rule you can do that using executeCommandLine and a timer.