Remove ZWave node fails. Even using Zensys?

Hi All

I tried to paid, unsuccessfully a Fibaro Button, on the 3rd go it worked and is recognised. Now I have two nodes that keep coming back up when I do a HabMin inclusion, 11 & 12. I tried the normal exclusion process , even a factory reset and then using a NOP frame inside Zensys and remove but the node is still visible

Is there a fool proof method to remove these nodes without resetting the controller.

Regards & Thanks

1 Like

Thank you sihui, ill give this a go!

With the OH 2.4 z-wave binding you can do this with HABMIN. On the right side select advanced settings. Her you can find “set device as FAILed” and “remove node from controller”. For me this is now working.

Use it the the mentioned sequence and wait 1min. for the second one. I think the controller must do a little work. After that the nodes are deleted from controller and should not come back. Sometimes they do, then just delete xml file and do it again.


@dastrix80 I guess the problem is that this is a battery powered devices. Those devices cannot simply be removed unless the controller marks it as failed. But I found a workarround in the Zensys tool. Just click on “Replace failed”, click on abort and then try to remove the device. If it fails try the same process again until it is removed.

I also just found out that it is not the “Replace failed” command that get’s this to work, but two other commands that are sent after this. I’ve also managed to create a .net application that does exactly this. If you are interested I can share it on Github. I hope I can also get this to work on linux with a .Net Core console application.

1 Like

I think people would be more inclined to trust the free Zensys Tool on Windows. They know the chip firmware best since they wrote it. :wink:

My software is also just using the dll’s from the Zensys Tool. (It is all based on .Net) I also tried with another library to get support for .net Core, but that doesn’t work for some reason.